1

I have a Raspberry Pi which is only used to display a web page on a screen. The pi connects to the internet over Wifi. When I'm on the same wifi I used to connect to my pi through SSH or VNC viewer using the default user "pi" and "raspberry" as password.

A few days ago I couldn't connect. When trying SSH I got: "Authentication failed, permission denied". Similar error with VNC.

I reset the password ("sudo passwd pi"). Problem solved, SSH access restored... VNC viewer worked as wel. But after 5 to 10 minutes, the password no longer worked. Resetting pw again still works, but only temporarily.

So it seems my password keeps changing? What can be the cause?

  • Using default user "pi" and "raspberry" is NOT recommended! – MatsK Aug 30 '17 at 13:23
  • Yes I know. This is a test setup at home. Are you suggesting someone got access? I'm no longer using the default password. – user63457 Aug 30 '17 at 13:28
  • I would have reinstalling the system, change password at first opportunity. Either your home network is hacked or someone at home is playing you a prank. – MatsK Aug 30 '17 at 13:44
  • check your access.log and auth.log – hcheung Aug 31 '17 at 6:28
  • 1
    I solved it by creating a new user and deleting the "pi" user afterwards. No problems so far. – user63457 Aug 31 '17 at 11:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.