1

I bought my first Pi, a Raspberry Pi Zero W 1.1 from CanaKit and I am having trouble with its USB port.

I tried booting latest Raspbian, Raspbian Lite and Noobs, but in all cases it's the same: no keyboard or mouse I connect works. In all cases the OS boots normally, I can see the screen in my TV and everything is OK. But when connecting USB devices, they don't work. Particularly when I connect USB keyboards, most light their "locks leds" for a fraction of a second and then they turn off. I also tried with a wireless mouse and keyboard, for the same results: I cannot connect keyboards or any input to my Pi's USB OTG. If I connect the power input to the "USB" port instead of "PWR", the Pi boots normally as well.

I am aware that only the micro USB labelled as "USB" is OTG while the one closer to the right labelled "PWR IN" is for power. I am using the correct port. I also have two working (tested with several mobile phones) USB adaptors to connect USB type A things on my Pi. I am using the official CanaKit Power Supply, as well as several 1 and 2 amp USB phone chargers to test, with same results with all power supply.

Looking for a way to know if either of the data lines on my Pi are fried, I stumbled upon this test: https://learn.adafruit.com/raspberry-pi-zero-creation/is-my-pi-zero-dead

I remove everything from my Pi (no SDCard, no usb adaptor, nothing), I connect it via it's USB port to my Windows machine but nothing happens (it should be recognised as a device). Because of this I am guessing there is indeed a problem with my data lines.

I bought this Pi last week in Canada while visiting, now I am back in my country pretty far from Canada. Returning it is not possible.

Is there something I am missing? Is there anything I can try to fix it?

Thanks

  • You really covered your bases! Most common cause of difficulty with USB peripherals on the Pi Zero is that it doesn't supply enough power, and this is remedied with an externally powered USB hub. Yes, the fact that you cannot enumerate "BCM2708 Boot" on your Windows PC suggests something else might but wrong e.g. data lines. What about the power lines? Pi Zero can be powered from either the PWR or USB OTG port. With SD card back in, does it boot when you attempt to power through the latter? Or if you can obtain or build a three-pin serial adapter, this can take out much of the guesswork. – jdonald Oct 30 '17 at 16:34
  • Ah let me see. (1) the micro USB connector near the PCB edge is for power, the other one further away is for USB devices.(2) So I used a USB hub (Note 1) to connect to this microUSB connector. (3) I connected keyboard and mouse dongles to the USB and can boot up RpiZ and everything goes well. Note 1 - I found only one old USB hub of my couple of USB hubs work. In other words, the RpiZ driver for USB hubs is NOT compatible to most USB hubs. PS - the USB hub that works does NOT need any external power. – tlfong01 Feb 4 at 8:56
  • I don't understand why do you connect you bare bone RpiZ directly to Windows PC. I never heard people doing this. The usual connection is using USB to UART/serial/TTL cable on both sides (with TxD and RxD crossing over), and use terminal emulator puTTY, CuteCom, miniTerm etc to talk to each other. But this assumes that your Rpi is working in first place. – tlfong01 Feb 4 at 9:04
1

It was the Pimoroni OTG cable that had been damaged....two of the pins inside the larger socket had been dislodged when i changed the keyboard to a wireless keyboard ....dongle thingy just before the very first boot of the zero. Hope this helps someone else to avoid the frustration.

| improve this answer | |
  • +1 for the answer :-) But it is always a good idea to take the short Tour and visit the Help Center to get an idea how things work here. – Ingo Feb 7 at 11:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.