0

Sorry but I'm loosing my mind with the Wifi on Rapsbian Jessie.

Here is the thing : At work we have a secure Wifi connection. We had instructions to get connect via ANDROID terminals, as following :

EAP: TTLS

Phase2: PAP

Login: MY@LOGIN.COM

Password: MYPASSWORD

Proxy->Manual

proxy.wifi.MYWEBSITE.COM

Port: 8080

It works fine.

But when I want to do the same on my RPi 3 .... the Wifi GUI doesn't support this, I installed Wifi-radar, but I can't find the field the put this setting.

I came to understand I need to edit wpa_supplicant.conf in /etc/wpa_supplicant/. So I used the help about wpa_supplicant.conf and added the following code (using sudo nano wpa_supplicant.conf) :

network={
    ssid="MYWIFI"
    key_mgmt=WPA-EAP
    eap=TTLS
    identity="MY@LOGIN.COM"
    password="MYPASSWORD"
    phase2="auth=PAP"
}

But even after a reboot, nothing.

As for the proxy setting i understood i had to create a 10proxy file in /etc/apt/apt.conf.d/ and write within this file : Acquire::http::Proxy "http://proxy.wifi.MYWEBSITE.COM:8080/";

but even after a reboot...nothing. What should I do?

0

There's no single proxy setting in Linux, unlike on Android, every program decides how to connect to a given URL on its own. Having said that, most sane Linux programs honor protocol_proxy variables. Try setting:

 export http_proxy=http://proxy.wifi.MYWEBSITE.COM:8080/
 export https_proxy=$http_proxy

in a terminal, and then run whatever program you want go online from the same terminal. Most of them will just work. Once you're satisfied with the solution, you can add those lines to your bash profile, so that they are automatically set every time you log in.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.