I have a rpi zero W with a raspbian lite (without desktop environment). I installed bluetooth support (bluetooth bluez bluez-utils), pulseaudio (pulseaudio pulseaudio-module-zeroconf alsa-utils avahi-daemon) and mpg123.

I paired a speaker and played some music and it works. But after a few minutes (one, two, ten...) the music stops and if the ssh connection is open the ssh session freezes. I tried with nohup, with other speakers, players... but the sound always stopps.

What am I doing wrong?

1 Answer 1


It's a bug of the Broadcom/Cypress bluetooth/wifi chip.

https://github.com/raspberrypi/linux/issues/1552, https://github.com/raspberrypi/linux/issues/1402 and more.

There's nothing I can do. I disconnected the on board bluetooth and added a new bluetooth (usb). Now it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.