2

I've been trying to fix this problem for 3 straight days now and I gets no love on the issue. I'm trying to install mosquito and IBM Watson On my Raspberry Pi 3 and there's an issue with the raspbian stretch OS. It seems like this would be solved a long time ago considering people Use RPI for a lot of IoT stuff.

I keep getting this same Error every-time and I cant find any real fixes. Should I just revert back to jessie? If so where can I find a copy of jessie cause all i see is stretch available.

Error:

The following packages have unmet dependencies: iot : Depends: libssl1.0.0 (>= 1.0.0) but it is not installable mosquitto : Depends: libwebsockets8 (>= 1.6.0) but it is not going to be installed

Does anybody have a fix for this out there???

1

Should I just revert back to jessie? If so where can I find a copy of jessie cause all i see is stretch available.

All old images is still there, just a bit hard to find.

Look here : http://downloads.raspberrypi.org

And then either:

 http://downloads.raspberrypi.org/raspbian_lite/images/

or

 http://downloads.raspberrypi.org/raspbian/images/

And there is a substructure depending on release date for the image.

The last Jessie is raspbian-2017-07-05.

  • 1
    I happened to find an old Jessie image on one of these laptops I don't use anymore and it works. I guess it's a true fact about waiting a couple months before downloading that hot new IS. – Jason Thomas Sep 6 '17 at 16:58
2

After you followed the instructions to install mosquitto and you get the 'unmet dependencies'error, do the following:

sudo aptitude install mosquitto

After a while you are then presented with some options to solve the issue. First option ("leave as is") chose 'n' then you are presented with an option to install the dependencies. chose "Y"

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.