1

So I'm trying to format my 64 GB SD card, using the instructions on the Raspberry Pi website (for Windows). They say to run the SD Formatter with Format Size Adjustment set to ON. But in the SD Formatter that they link to, the option doesn't exist.

Every place I have looked uses the exact same instructions, with pictures showing the selection of Format Size Adjustment, but they all seem to be using versions 3 or 4 of the SD Formatter. It seems they have upgraded to 5 and no longer have Format Size Adjustment as an option?

Figuring that maybe the new version simply handles it automatically, I tried following the rest of the instructions (for installing NOOBS). But when I tried booting up the Pi, I got 2 green flashes and that's it - which most information says is caused by the disk not being formatted correctly.

So now I'm back where I started. I tried finding earlier versions of the SD Formatter but wasn't able to. Anyone know what to do here?

  • 2
    You should try with a SD card that has maximum of gigabytes: 32 – kuzeyron Sep 4 '17 at 18:47
  • Although it requires gaining some familiarity with the linux tools such as gparted and resize2fs, you could just forget about this and grow it post install -- for which ideally you need another linux system (e.g., a live CD or virtual machine, or two SD cards and a USB adapter) which is a good thing to have if you are going to be fiddling with Pi's in any case. – goldilocks Sep 4 '17 at 20:21
0

Here is a quote from this page about formatting SDXC SDCards:

According to the SD specifications, any SD card larger than 32GB is an SDXC card and has to be formatted with the exFAT filesystem. This means the official SD Formatter tool will always format cards that are 64GB or larger as exFAT.

Also, consider that the SDCard you have made is fine and that there is a boot problem with the Raspberry Pi.

There is a (sticky) Rraspberry Pi web page you can go to and read about a number of common boot problems and their solutions.

That said, using an inadequate power supply is one of the more common problems. Especially when using one of the more powerful Raspberry Pi boards.

The following table can be found here on the web. Note it is recommended to use a 2.5 Amp power supply with the most recent Raspberry Pi 3 Model B.

Product     Recommended PSU current capacity    Maximum total USB peripheral current draw   Typical bare-board active current consumption
Raspberry Pi Model A    700mA   500mA   200mA
Raspberry Pi Model B    1.2A    500mA   500mA
Raspberry Pi Model A+   700mA   500mA   180mA
Raspberry Pi Model B+   1.8A    600mA/1.2A (switchable)     330mA
Raspberry Pi 2 Model B  1.8A    600mA/1.2A (switchable)     350mA
Raspberry Pi 3 Model B  2.5A    1.2A    400mA
Raspberry Pi Zero W     1.2A    Limited by PSU, board, and connector ratings only.  150mA
Raspberry Pi Zero   1.2A    Limited by PSU, board, and connector ratings only   100mA
  • Recent vintages of Windows tend to drop placing partition information on SDCards and possibly other similar media. This may be an attempt to preserve more memory for files. But, as such media has literally been doubling in size almost yearly, this argument seems fragile at best. This may be the reason you need a special SDCard formatter - to format SDCards with partition information like we all used to do it. – st2000 Sep 4 '17 at 20:40
  • I'm not sure how the first quote is supposed to help. Do you mean that it's not supposed to give the Format Size Adjustment option? If not, why would that be the first line on a page specifically concerning cards larger than 32 GB? The power supply I'm using is a lithium ion battery from Adafruit, plugged directly into the Pi. The red light isn't showing any issues, so I thought that meant the power supply is good. (It's a Pi 3 Model B) – IndigoFenix Sep 5 '17 at 4:22
  • I tend to create all my SDCards in a Linux environment. The upside is that you need to understand everything that is going on. Of course that can be the downside as well. I am not familiar with the Windows tool you are using. The downside to these tools is that instructions can be obsoleted when new versions of the tool become available. The quote concerns you as your SDCard is larger than 32GB. So you need to be concerned that the tool you are using can handle such large SDCard. How you go about that is up to you. I would down load the newest version of the tool and try again. – st2000 Sep 5 '17 at 16:09
  • As for the power, Adafuilt sells a number of LION batteries. I have no idea if the internal resistance of the battery will drop the voltage below the operating point of the Raspberry Pi. Please note, the newer Raspberry Pi with multiple cores will consume much more power when asked to do complex tasks. I was using an under powered power supply and did not reset my Raspberry Pi until I ran face recognition software 10s of minutes after I booted up. – st2000 Sep 5 '17 at 16:17
0

use a live copy of gparted loaded to a thumb drive and format for FAT 32. Most systems will try for exFAT on larger cards

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.