The official Raspberry Pi display has a resolution of 800x480.

However, Raspbian doesn't have an option for this resolution under Raspberry Pi Confiugration->System-> Set Resolution.

How do I adjust the resolution of the pi to take advantage of exactly 800x480 pixels?

Edit: I should also add, the display setting I have set is 720x480, however, the screen only seems to be displaying a 400 pixel height.

2 Answers 2


I found the answer here: https://www.raspberrypi.org/forums/viewtopic.php?f=108&t=184762

and copied below:

Decided to get an official 7in touch display but instantly figured out that 800x480pixel resolution is a little too low for most of my use cases (my custom 7in is 1280x800pixels)

Don't know if this has been posted already but you can simple get to see some more content on the official display by changing the frame buffer size in config.txt I think that 1024x614 pixel is a good trade off between quality and achievable resolution (see screen capture below).

cd /boot
sudo nano config.txt

and change frame buffer lines to

#uncomment to force a console size. By default it will be display's size minus
# overscan.
framebuffer_height=614 ... reboot and check resolution with

fbset -s

Pi showing it is in 1024x614 resolution

  • This procedure does not work with Pi 4 & the latest version of Raspberry Pi OS. I think because of HDMI hardware changes. Can anyone provide the procedure for newer versions of the hardware/OS?
    – metaColin
    Jun 5, 2020 at 23:35

The easiest way I've found and it works for me: https://www.raspberrypi.org/forums/viewtopic.php?f=29&t=24679

Just add next row to the end of /boot/config.txt This file is also visible from boot disk if you read SD card on your laptop.

hdmi_cvt=1680 1050 60 5 0 0 1



hdmi_cvt=<width> <height> <framerate> <aspect> <margins> <interlace> <rb>
width        width in pixels
height       height in pixels
framerate    framerate in Hz
aspect       aspect ratio 1=4:3, 2=14:9, 3=16:9, 4=5:4, 5=16:10, 6=15:9
margins      0=margins disabled, 1=margins enabled
interlace    0=progressive, 1=interlaced
rb           0=normal, 1=reduced blanking

The first three arguments are required. The remaining ones are optional. aspect defaults to 16:9 if not specified.

Not the answer you're looking for? Browse other questions tagged or ask your own question.