0

I've been trying to get audio to work on my Pi3. I'm able to get audio to my powered speakers through the 3.5mm jack. But like lots of others, I've encountered the background hiss that makes it nearly-impossible to listen to. I have a VGA Monitor connected to the PI with an HDMI-VGA cable (so, there are no speakers on the monitor). I purchased an HDMI converter with a 3.5 mm jack, thinking I could then run the audio right through the HDMI port. I plugged the powered speakers into the 3.5mm jack on the converter...No luck, no sound at all. I've tried amixer cset numid=3 2, with no luck, and I've gone through the config screen (sudo raspi-config), but also with no luck.

I'm hoping someone here has had similar problems (and fixed them!), or can otherwise help me out. I'm pretty new to this, so my technical skills are limited at best.

Thanks!

1

You should try adding the line

hdmi_drive=2

to your /boot/config.txt file. As documented at https://www.raspberrypi.org/documentation/configuration/audio-config.md

Apparently both the raspi-config method and amixer commands (as you've already tried) can fail to make sound be sent over HDMI due to it setting itself into DVI mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.