1

I've been scouring the net trying to find the answer to this and all answers that are close talk about not connecting to the net. I have no problems on the internet, I am typing this on the pi3 that I'm having problems updating with.

I am hit with the following error upon attempting to update. Please help:

W: Failed to fetch http://mirrordirector.raspbian.org/raspbian/dists/jessie/InRelease Unable to find expected entry 'main/binary-i386/Packages' in Release file (Wrong sources.list entry or malformed file)

E: Some index files failed to download. They have been ignored, or old ones used instead.

  • If I enter the address of the file into a web browser i hit the file immediately. mirrordirector.raspbian.org/raspbian/dists/jessie/InRelease – Frank Sep 6 '17 at 3:03
  • 2
    i386 indicate that it is looking for the wrong architecture, a Raspberry Pi is a ARM based processor. – MatsK Sep 6 '17 at 4:17
  • 1
    Ok... That makes sense but how do I point it to the right architecture? – Frank Sep 7 '17 at 3:45
  • 1
    armv7.1cat /etc/apt/sources.list deb mirrordirector.raspbian.org/raspbian jessie main contrib #non-free rpi # Uncomment line below then 'apt-get update' to enable 'apt-get source' deb-src archive.raspbian.org/raspbian jessie main contrib non-free rpi – Frank Sep 7 '17 at 18:49
  • 1
    dpkg --print-foreign-architectures = i386 – Frank Sep 7 '17 at 18:51
1

You should remove the i386 architecture since you are running a ARM architecture. But first you need to remove packages from the wrong architecture that have been installed:

apt-get purge ".*:i386"

And then:

dpkg --remove-architecture i386

Ref.: https://wiki.debian.org/Multiarch/HOWTO

  • 1
    Thanks again. And thanks for the link to educate me. I appreciate your help. @MatsK – Frank Sep 10 '17 at 11:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.