0

After installing Raspbian Stretch Lite, I would like to install a GUI: Choose LightDM, but after reboot, when I insert my username and password (both correct), the system will come back at the same screen, asking me to insert the username and password again. How can I solve this?

  • How did you install the GUI? You may be missing dependencies. – bobstro Sep 7 '17 at 15:29
  • 1
    GUI = Desktop but LightDM is a Login Manager! – MatsK Sep 7 '17 at 22:29
  • @MatsK it's what raspi-config installs. What do suggest ? – mckenzm Oct 1 '17 at 8:58
  • ???? raspi-config doesnt install GUI/Desktop stuff. Reinstall the SD card. – MatsK Oct 1 '17 at 9:08
0

Try:

systemctl get-default

And if it is not graphical.target:

sudo systemctl set-default graphical.target
0

There is a very good article at https://www.raspberrypi.org/forums/viewtopic.php?t=133691 that explains what is need and several different options to add GUI to Raspbian Lite.

This work for me on Raspbian Stretch Lite:

  1. Xorg sudo apt-get install --no-install-recommends xserver-xorg -y

  2. Pixel GUI sudo apt-get install --no-install-recommends raspberrypi-ui-mods lxterminal gvfs -y

  3. sudo raspi-config choose "3 Boot Options - Configure options for start-up", "B1 Desktop / CLI - Choose whether to boot into a des", "B4 Desktop Atologin Desktop GUI, automatically logged in as 'pi' user", "Ok", and reboot.

0

This did not work for me.

I did the above steps from both posts, but it still just restarts after entering username/password. To fix this, I did the additional steps:

sudo apt-get install lxde --fix-missing
sudo apt-get install xinit
startx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.