0

I'm completely stuck. I have Raspberry Pi Zero W and I'm trying to get the built-in Wi-Fi to work. After a clean install of 2017-08-16 Raspbian Stretch, when I click on the Wi-Fi button in the top right screen, it says "no wireless interface found". When I do lsmod, I see:

pi@raspberrypi:~ $ lsmod
Module                  Size  Used by
bluetooth             374820  0
fuse                   94600  3
cfg80211              525806  0
rfkill                 21373  3 bluetooth,cfg80211
evdev                  11746  1
snd_bcm2835            23131  1
snd_pcm                97825  1 snd_bcm2835
snd_timer              22706  1 snd_pcm
snd                    68784  5 snd_timer,snd_bcm2835,snd_pcm
bcm2835_gpiomem         3791  0
uio_pdrv_genirq         3718  0
uio                    10166  1 uio_pdrv_genirq
fixed                   3029  0
i2c_dev                 6642  0
ip_tables              12512  0
x_tables               20921  1 ip_tables
ipv6                  384532  14

So if I'm correct, that suggests that the Wi-Fi module is loaded. But when I do ifconfig -a, I see:

pi@raspberrypi:~ $ ifconfig
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Which suggests that I'm missing a driver. But if I'm correct the driver for the build in chip should be built-in to Raspbian. I also tried some other hopeless things like adding my SSID and password to the wpa_supplicant.conf file and doing the same thing on Stretch Lite and 2017-07-05 Jessie and Jessie lite. Plus I tried placing my SD card in old Raspberry Pi 1 and updating and upgrading all packages with:

 sudo apt-get update
 sudo apt-get upgrade

None of that worked. Do I have a broken chip or am I just missing something?

3
  • What is the output from ifconfig -a?
    – MatsK
    Sep 7, 2017 at 21:43
  • I'm having the same problem as you, I already have a topic in the official Raspberry forum and also a topic in reddit. If you find out something please let me know! Reddit:<reddit.com/r/raspberry_pi/comments/6yzdys/…> RaspberryPi Forum:<raspberrypi.org/forums/viewtopic.php?t=192665> Sep 9, 2017 at 8:17
  • From lsmod results there doesn't seem to be any wireless adapter. A wireless-enabled Pi Zero must look exactly like this (front side) and this (back side). Pay attention to the triangle-shaped antenna on the front side.
    – user29510
    Oct 12, 2017 at 9:38

4 Answers 4

1

The command ifconfig is only showing interfaces that are up.

If you append a -a, ifconfig -a it will show ALL interfaces, also the interfaces that are down.

3
  • Thank you Mats, I tried ifconfig -a but I still only see the loopback interface
    – martijns
    Sep 8, 2017 at 5:37
  • 1
    @martijns Just a double check, on the backside of the Raspberry Pi Z W below the raspberry is there a text "Uses antenna tech...."?
    – MatsK
    Sep 9, 2017 at 5:14
  • There is also the commands lspciand lsusb that will list devices on either the PCI and the USB bus.
    – MatsK
    Sep 9, 2017 at 5:32
0

Same problem on a unit I bought a while back. Today I bought another Pi Zero W only to have the same problem with it. Poking around on the web I found a post where somebody recommended using PiBakery. This lets you preconfigure an image on a PC or Mac then write it to the SD card (including the WiFi SSID and password). I did this, and it worked. I'm up and running on both cards now.

0

I ordered a new raspberry pi zero w last week and today I placed the sd card I used in my old pi in this new one and the wifi worked right away. So I guess I just had bad luck and received a broken unit.

1
  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year.
    – Ingo
    Mar 16, 2020 at 9:04
0

Create a new file called wpa_supplicant.conf on the boot directory containing the following text:

country=AU
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
    ssid="MyWiFiNetwork"
    psk="aVeryStrongPassword"
    key_mgmt=WPA-PSK
}

Do not use notepad if editing the file on a windows PC. Use something like Notepad++.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.