1

I upgraded to Stretch following the normal procedure, changed the repositories, etc. But after all, I'm still running Chromium 56, a older version of the browser.

When I try to update the system, it checks both repositories, Jessie and stretch, I don't know why because I replaced Jessie with stretch source.list.

Now, no new version of Chromium appears when I run sudo apt upgrade... maybe the repository, maybe something else... I don't know.

By the way, I have a medium-high end PC, but still prefer the silent browsing of my Raspberry Pi 3... found it so exciting.

2

First, to make it clear: You need to refresh the package list by runnibg sudo apt update everytime before executing sudo apt upgrade.

But this isn't the nain problem. The reason why you are still running a older version of Chromium (even if all packages are up to date) is that this older version is available in the repository. As you can check here the version of Chromium is 60.0.3112.

I was not able to find the latest stable version (61) on the Chromium website to download. Switching to Chrome is also not possible because Google only offers build for the x86 and amd64 platform.

As Chrome/-ium 61 was released just three days ago (see here) I would recommend waiting until Chromium 61 becomes available in the repositories.

  • Thanks to reply. Yes, I do it every time i wanna upgrade the system, sudo apt-get update and then upgrade. Ok, i will wait a week and tell you whats up. by the way, i have the 56 version, not the 60. – Salvador Liébana Sep 8 '17 at 18:42
  • I just installed raspbian yesterday, Debian 9 Stretch... I did aot-get update and still, chromium-browser is stuck at 65?? while the online upstream repo claims the latest is 71. Wth. packages.debian.org/stretch/chromium – Ray Foss Jan 17 at 19:14
0

Since you upgraded from Jessie, you may have missed a few source lists to point your apt repos to. Check these two files and make sure any instances of jessie have been replaced with stretch:

  • /etc/apt/sources.list
  • /etc/apt/sources.list.d/raspi.list

I was encountering the exact same problem until I updated the 2nd list, and then when I ran sudo apt-get update and sudo apt-get install chromium-browser I was finally able to download the latest version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.