I have tried to install Raspbian Desktop on a 16GB Samsung Card using Etcher.

First time, the card becomes corrupted or broken, so that when I try to write it says "Read / Write Error". Windows says unable to format, the first partition for 50MB appears in desktop but second partition doesnt appear.

I returned it to the shop as it has warranty and replaced it with new one.

Now although Etcher writes the image well and Pi 3B was able to boot, it shows some ext4 parts missing on boot up. I assumed the image wasn't written correctly and I tried to write the image again.

This time the SD card again gets same behaviour like the previous card. "Windows was unable to format" error and second partition disappears from computer although first 50BM partition appears I tried to format from Android mobile and it was also unable to format the card.

How do I recover the card? What are the best practices to write to an SD card without any concern of corruption?

  • Try with Win32disk imager instead Etcher. If you have no warrenty it is better to forgot about that SD card. – Arun K S Sep 12 '17 at 5:49
  • I have warranty and replaced 3 cards so far now, will try using Win32Disk with 4th card and update – Shan Khan Sep 13 '17 at 11:11
  • any updates ? I am facing similar issue – dparkar Jan 4 at 8:21

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.