My Raspbmc-based media centre has been running happily for a couple of months, undisturbed. It's not on constantly; I don't have enough power sockets for the TV, stereo, RPi and games consoles, so I swap things around. It's usually just on for a few hours most evenings. I always shut it down properly from the menu, and make sure it goes completely dead before unplugging the power.

A couple of days ago, it froze completely; there was no response using the IR remote or the USB keyboard. I tried to ssh in, but it wouldn't accept the connection. I left it for a few minutes, but was forced to conclude that it was totally stuck, and pulled the power.

Since then, I've been unable to boot it. I tried a fresh Raspbmc install on a clean SD card, but the behaviour was exactly the same. I noticed that the power supply on the USB hub I'm using was whistling slightly in the way that can mean a problematic connection, so I unplugged all of the peripherals except the IR receiver (which is very low-power) and powered the RPi directly from a 5V 1A smartphone charger (which I've used successfully in the past), but this made no difference.

The error I get is as follows:

init: udev pre-start process (41) terminated with status 127

I've searched for this, but I get a lot of results that refer to other processes, other Linux builds, other hardware... I'm not particularly experienced with Linux, so I'm not 100% sure what's relevant and what's not, but so far I haven't found anything that looks like it'd help me.

Can anyone suggest something I might have missed? A clean OS install, a stripped-down setup, a known good power supply... I'm not sure what else to try.

3 Answers 3


I don't remember the error that I received, but I had similar symptoms using some cheap off-brand SD card. After spending the couple extra bucks for a SanDisk life is good.

  • I tried it with a fresh card, and it boots just fine. It looks like continual journal writes have nuked the card... might be worth looking at a different filesystem, I think. Commented May 7, 2013 at 8:23
  • Glad you got it figured out... I wonder if there is a daemon that can be disabled to reduce unnecessary R/RW on the SD card... I would think would be the same process as optimizing for a SDD Hmmm.. Time for some googleing I think!
    – Butters
    Commented May 7, 2013 at 15:34
  • A friend with better Linux-fu than I has suggested switching filesystems; I was initially under the impression that Raspbmc used EXT-3 or -4 which (apparently) does a lot of R/RW to the journal, but it turns out I was looking at the wrong device and now I'm not sure which filesystem it uses. At any rate, the cause was definitely a dead card, and it's not that old so I'm pretty convinced that something is writing to the card much more than necessary. Not sure how Raspbmc would behave under a different filesystem though, or if it would even run. Definitely some googling needed. Commented May 7, 2013 at 15:48

It sounds like this is an hardware issue. If you haven't already I would recommend that you unplug everything besides the display. This includes network cables, keyboards etc. You could also try a different SD card, as it's possible that it's the SD card itself causing problems.

But, most likely there is something wrong with your Raspberry Pi. And I would recommend that you contact your vendor to see if you can get it replaced.


I just had this issue also. Same error codes at boot, or maybe I'll call it 'not boot' but anyway....

I received this error after attempting to use the "super" setting in the raspbmc settings section of raspbmc. It appears that the overclocking is the culprit. I'm able to edit the config on my PC and then pop the SD back into the Pi, no change.

Since it is pretty simple to go through and set up my preferences I am simply reinstalling the OS to the SD.

There is nothing wrong with the Pi though, my other SD booted just fine with Raspbian Wheezy on it. And I am currently installing the Raspbmc OS on the same card it was on prior to this error. So there is nothing wrong with the card either.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.