0

I have an old Raspberry Pi 1 Model A that I am trying to fire up for the first time. I followed the Ethernet Gadget tutorial exactly:

  1. I inserted an SD card into my laptop (MacBook Pro)
  2. I used Etcher to flash Raspbian Stretch Lite to this card
  3. On the SD card, post-burn, I then modified the config.txt and cmdline.txt files exactly the way that gadget tutorial (above) specifies
  4. I took the SD card out of my laptop and put it into the SD clot on my RPi
  5. I powered my RPi on by taking a USB A-to-MicroB cable, and plugging the "A end" into my laptop, and the "MicroB" end into the Micro USB port on my RPi. I can confirm that I do see the red "PWR" light on the RPI board.
  6. I login to my router's UI and confirm that I don't see any wired connections to my router; this is correct as of this point there shouldn't be any.
  7. I connect my RPi to my router via Ethernet cable and wait a few mins
  8. I refresh my router login screen and I do see my RaspberryPi showing up as a wired connection
  9. I open up a terminal on my Mac and try to SSH in, but am getting errors (see below).

Here's a picture of my setup:

enter image description here

You can see:

  • The gray Ethernet cable between my router and my RPi
  • The black power cable (USB) between my laptop and my RPi (the red power light is lit up on the board in the top right corner)
  • The SD card is plugged into the USB-SD adapter, and that adapter is plugged into the USB port on my RPi

So for SSH, first I try:

ssh pi@raspberrypi.local
ssh: connect to host raspberrypi.local port 22: Connection refused

So no dice. Then I try the same but with 192.168.0.14 (which is my pi's IP address, according to my router):

ssh pi@192.168.0.14
ssh: connect to host 192.168.0.14 port 22: Connection refused

To me this means the RPi is either not starting up correctly, or has a firewall (ipconfig) issue, or that something is wrong with sshd on the pi. Any ideas as to what my next step for troubleshooting is?

  • 1
    As stated in my answer to your previous question the ethernet gadget tutorial only works with a pi zero or xero W. WHat is the output of ifconfig? Have you checked the admin pages in your router to see if the Pi is connected? Assuming your Mac and Pi are on the same network have you tried ssh raspberry.local? – Steve Robillard Sep 14 '17 at 16:20
  • Thanks @SteveRobillard (+1) - you want me to run ifconfig on my Mac, or my RPi? – smeeb Sep 14 '17 at 16:21
  • 1
    On the Pi? BTW what is the model number of that plano box the Pi is sitting on (it is usually on the bottom). I am looking for something that size. – Steve Robillard Sep 14 '17 at 16:26
  • Okay I think we're getting to the root of my confusion, so bare with me here please! How can I run ifconfig on my RPi if I can't SSH into it from my Mac?!?! That's my problem, I just want to get into the dang RPi! Also, I picked the Plano box up at Dicks Sporting Goods, Model #3504 (hope that helps!). – smeeb Sep 14 '17 at 16:29
  • 1
    This will make things easier connect the ethernet adapter to the pi via a USB hub, connect the pi to a tv or monitor via HDMI and connect a keyboard/mouse to the USB hub as well. Your trying to do this blind. Also, you did not answer my question about connected devices in your router's admin interface. – Steve Robillard Sep 14 '17 at 16:44
2

From your picture and description it's clear there is no SD-Card in the proper slot on the back side of the RPi.

While actual RPi 3 can be made to boot from Usb there is no chance for your model, so put the SD card in the proper slot before trying anything else.

  • Thanks @LotPings! For the SSH/network connection do you recommend I try the router-based setup in the first photo above, or the Mac/USB-ethernet adapter setup in the 2nd photo? – smeeb Sep 14 '17 at 18:17
  • Til now I always started with a keyboard with trackpad and a hdmi monitor for setup before enabling ssh - so no own experience with headless setup. – LotPings Sep 14 '17 at 18:21
  • Hey!!! I plugged the SD card into the SD slot on the back of the pi (I didn't even know that was there!!!) and gave it power & ethernet and immediately see all sorts of other onboard lights turning on (FDX, LNK, 100, etc.). I then tried ssh pi@raspberrypi.local and now I'm getting ssh: connect to host raspberrypi.local port 22: Connection refused, which means I'm a little bit further and on the right track! Thanks you so much! Also... – smeeb Sep 14 '17 at 19:14
  • I assume this means that either SSH isn't installed/listening on port 22, or that ipconfig/firewall is blocking it somehow? Any suggestions for what I can try to troubleshoot from my Mac or router? Or am I gonna have to hook it up to a monitor to make any more progress? – smeeb Sep 14 '17 at 19:15
  • Default user is pi and password is raspberry so what did you enter? See raspberrypi.org/documentation/linux/usage/users.md – LotPings Sep 14 '17 at 19:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.