1

I have two of the same RPi boards (3 Model B, a02082)

Used the for some time, installed different software on them. But just ran apt-get update and apt-get upgrade today on both boards.

On the board where i2c is working it shows lsmod | grep i2c

i2c_bcm2708             4834  0
i2c_dev                 5859  0

and from dmesg | grep i2c

[    3.188212] i2c /dev entries driver
[    4.698330] bcm2708_i2c 3f804000.i2c: BSC1 Controller at 0x3f804000 (irq 83) (baudrate 100000)

On the board where i2c is not working it shows lsmod | grep i2c

i2c_bcm2835             7167  0
i2c_bcm2708             5994  0
i2c_dev                 6913  0

and from dmesg | grep i2c

[    2.983772] i2c /dev entries driver

/etc/modules are the same on both boards.

Correct addresses are detected on both boards with i2cdetect -y 1

I have tried to unload and load the drivers, to get the bad board to work. But no luck. I need some ideas to move forward.

1

Now I made it work partly, thanks to this page: https://github.com/raspberrypi/firmware/issues/828

It seams the reason it worked on one RPi board and not the other was that one was updated with the latest version of the driver (not working) and the other had an older version (still working). Driver was updated summer 2017.

I did the following to make it work on both boards:

Download this file FTP or copy it by other means to the Raspberry Pi.

ls -l 

check that it is 886 bytes in size.

sudo cp i2c1-bcm2708.dtbo /boot/overlays/i2c1-bcm2708.dtbo
sudo nano /boot/config.txt

Add the following line at the end dtoverlay=i2c1-bcm2708 and save and exit.

sudo reboot

At this point I got my Python sample program running. But my two C# shell apps, which was working on one of the RPi boards before, still did not work. I find this very odd and I will continue to debug. ;-) Please give suggestions, how to solve the last part...

  • Now I have solved the last problem too; where I was unable to run several peripherals on the same i2c bus. It turned out to be a problem with the i2c library I was using. I changed to RPiCSIO and now everything works perfect :-) github.com/thomas3d/RPiCSIO – Thomas Jam Pedersen Sep 17 '17 at 22:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.