1

OK - this is frustrating...there are lots of messages on this board and others with the same problem, yet none of the solutions provided seem to work in my case.

I'm using a Pi-3, with a fresh install of Stretch. I have an NFS mount on my Synology NAS that I want to mount on startup. Mounting the share manually works fine, but when adding to fstab it will not mount on startup, nor will it mount with a "mount -a":

pi@webserver:~ $ ls /mnt/www/
pi@webserver:~ $ sudo mount -a -v

/proc                    : already mounted
/boot                    : already mounted
/                        : ignored
/mnt/www                 : ignored

pi@webserver:~ $ cat /etc/fstab 
192.168.2.50:/volume1/web /mnt/www nfs rsize=8192,udp,cto,noatime,intr,x-systemd.automount,noauto,nfsvers=3 0 0

pi@webserver:~ $ sudo mount -t nfs 192.168.2.50:/volume1/web /mnt/www

pi@webserver:~ $ ls /mnt/www/

grade3  grade6  index.html  innovateprayrepeat  jenniferking  kridan  web_images

Perhaps it's an issue only with the latest release? I am mounting a share on this same NAS just fine on another pi I have with Jessie running.

I've tried all of the following combinations in fstab to no avail:

192.168.2.50:/volume1/web /mnt/www nfs nouser,atime,auto,rw,dev,exec,suid 0   0
192.168.2.50:/volume1/web /mnt/www nfs rsize=8192,udp,cto,noatime,intr,x-systemd.automount,noauto,nfsvers=3 0 0
192.168.2.50:/volume1/web /mnt/www nfs4 rw,intr,x-systemd.automount,noauto 0 0
192.168.2.50:/volume1/web /mnt/www nfs4 _netdev,noauto,x-systemd.automount 0 0

What does it mean when the mount reports "ignored" for my share? There are no clues in dmesg output either. For everyone else, the key to fixing seemed to be the use of "noauto,x-systemd.automount" but that hasn't helped here.

I even used raspi-config to ask it to wait for network on startup but that made no difference either.

Someone point out what must surely be a simple mistake.

Thanks in advance.

1

I was just able to get this accomplished with stretch version and NFS to my Synology NAS.

Create the mount point you want:

sudo mkdir /mnt/NAS

Mounted it manually first:

sudo mount -t nfs 192.168.1.100:/volume1/video /mnt/NAS

Checked to make sure the path worked:

cd /mnt/NAS
ls -al

All was good, so put it into fstab for mounting at boot. I put this in at the very end of fstab (edit via sudo nano /etc/fstab):

192.168.1.100:/volume1/video /mnt/NAS nfs defaults 0 0

I rebooted and verified that it was there.

I hope you had the same success I did!

0

You need to install network-manager:

sudo apt-get install network-manager
systemctl enable NetworkManager.service
systemctl start NetworkManager.service
0

If you do install network-manager you may run into problems if you are running on wifi with a dongle...

Install also

network-manager-gnome

Reboot, then setup your wifi connection with the new applet that appears in the taskbar. Then reboot again.

This did work, and brought my nfs share up on boot :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.