2

I am new to using Raspberry Pi devices. I have a problem with enabling the cameras on the Compute Module 3. When I run 'vcgencmd get_camera' I get the output 'supported=1, detected=1'. The connections are all correct as described in Raspberry Pi documentation.

I think I have downloaded the single blob file when I run sudo wget http://goo.gl/U4t12b -O /boot/dt-blob.bin, because the command outputs supported=1. Hence I think the problem is with the bin file and not the hardware connections.

How could I enable both the cameras? How to download dt-blob-dualcam.dts? A detailed command with explanation would help as I am new to this. I couldn't really understand the tree source files document. I have also checked out https://www.raspberrypi.org/forums/viewtopic.php?f=98&t=174347

Am I missing something or did I get anything wrong?

1

I never used compute module with dual camera, but I can show you how to get your missing .dtb file.

First download the dt-blob-dualcam.dts file in our home directory.
cd
wget https://raw.githubusercontent.com/raspberrypi/documentation/master/hardware/computemodule/dt-blob-dualcam.dts

Next compile it with :
dtc -I dts -O dtb -o ~/dt-blob-dualcam.dtb ~/dt-blob-dualcam.dts

Copy th generated dt-blob-dualcam.dtb file in the /boot/overlays folder:
cp ~/dt-blob-dualcam.dtb /boot/overlays

Last step tell the system to use this device tree file. Edit /boot/config.txt file and add at the end :
dtoverlay=dt-blob-dualcam

  • I downloaded dt-blob-dualcam.dts file and its getting downloaded as an audio file. When i compile the next command it says no such file or directories. please help – raspbiangetsCRAZY Sep 19 '17 at 13:47
  • Your DTS file is not really an audio file, it's only an extension homonimy. I'm updating the command line in the answer – Technico.top Sep 19 '17 at 20:07
  • Still it gets downloaded as an audio file :( How could i save it as a .dts file? – raspbiangetsCRAZY Sep 20 '17 at 9:33
  • Thanks alot :) Somebody also helped me to find a way. Even if it gets saved as an audio file the contents doesn't change so its fine to continue with the next set of commands. – raspbiangetsCRAZY Sep 20 '17 at 13:24
0
$ sudo wget https://www.raspberrypi.org/documentation/hardware/computemodule /dt-blob-dualcam.dts
$ sudo dtc -I dts -O dtb -o dt-blob-dualcam.dtb dt-blob-dualcam.dts
$ sudo cp dt-blob-dualcam.dtb /boot/dt-blob.bin

This worked for me to enable both the cameras :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.