2

I bought a raspberry pi B+ model about a year ago to get into raspberry pi projects and it worked perfectly fine after installing Raspbian. I had done a project to drive a car over IP through an app, but it just stopped working. So I've been searching different forums and saw some pretty consistent answers stating to format the sd card and write the img to it again. I've done this on a windows computer using win32 disk imager, and now I'm getting this weird screen that says the following:

Could not expand filesystem, please try raspi-config or rc_gui.
Boot and root partitions are on different devices.

This is the only dialog I see and it provides an "OK" button. If I hit OK the "rainbow" splash screen (that's the best way I can think to describe it, I apologize for my ignorance) shows briefly and then the same dialog. Can someone point me in the correct direction? enter image description hereenter image description here

1

Did you download the latest Raspbian Stretch with Desktop ?

https://www.raspberrypi.org/downloads/raspbian/

I would suggest using Etcher to write the image to the sd card.

https://etcher.io

You don't need to format the sd card nor unzip the image. Etcher will unzip the image and overwrite everything on the sd card (hence no formatting required).

  • I will try this and let you know what happens. – 1QuickQuestion Sep 18 '17 at 9:12
  • @CoderMile still having the same issue. – 1QuickQuestion Sep 18 '17 at 9:37
  • Same error message ? Are you using a good power supply ? Have you got a different sd card you can use ? What size card is it ? – CoderMike Sep 18 '17 at 9:43
  • Yes, same message. I tried using an SandDisk Ultra (not sure if that helps). – 1QuickQuestion Sep 18 '17 at 10:05
  • What size is the card? What power supply are you using ? I use SanDisk always been good for me. Have you got a spare card you can try? – CoderMike Sep 18 '17 at 10:11
0

I recently ran into an issue upgrading my pi's sdcard while trying to recover my old data. In the midst of it I decided to just start over with Noobs, and was having issues, did a search, and it ironically lead me back to my own thread. Just wanted to let people know what really helped me flawlessly:

NOTE: I am using a macbook Pro running Sierra

1.) Go to the Raspberry Pi site & download the latest version of Noobs

2.) Unzip the file on your desktop (or the directory location you prefer) using the archive utility tool (right click->open with->archive utility)

3.) Using the Disk Utility Tool (default on mac), format the your sd card to "(DOS) FAT", and then download the SD Formatter tool from https://www.sdcard.org/downloads/formatter_4/ and erase the drive

NOTE: I know that sounds redundant but that's literally the only way I could get it to work

4.) Copy and paste the contents of the unzipped NOOBS folder onto the formatted drive, place it into the Raspberry Pi, then power it up.

This worked for me perfectly. For some reason etcher didn't work at all for me, but the copy & paste worked great.

0

This might be a bad explanation as I don't fully understand it, but you have to write a filesystem to the entirety of the card first, before later partitions can be expanded to fit. The format itself persists even if the partitions are deleted.

I replicated the issue on Linux by taking a fresh SD card and doing:

dd if=raspbian.img of=/dev/sdX bs=4M

The image was successfully written, but could not be expanded. It was the exact same issue you had.

I deleted the partitions, created by the raspbian image, using fdisk and created one big partition across the card. I formatted it with mkfs.vfat. Then I wrote the same image using the same command to /dev/sdX (NOT /dev/sdX1 !) Works great now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.