1

I'm trying to set up a home automation system using a Raspberry Pi 3 (with a RaZberry 2 Z-Wave controller) and the Z-Way Z-Wave Controller. I've set up my Pi with a complete SD card image, as described here (which I believe is based on Jessie).

Because the Z-Way software is set up to allow connecting to the Pi using its own wireless network (I assume, in retrospect), the SD card image is configured to have the Pi's wifi act as an access point. The result is that the Pi has to be connected to my router using a cable for Internet access. I would instead like to connect the Pi to my router wirelessly, but I'm having problems figuring out how to do this (probably because my lack of Linux knowledge...).

So, the question is: How can I stop the wifi adapter on my Pi acting as an access point, and instead have it work like a "normal" wifi adapter to connect to my wireless network?

What I've tried this far:

First I connected to my Pi using PuTTY and followed this documentation on how to set up wifi from the command line. My /etc/wpa_supplicant/wpa_supplicant.conf is according to the example, but it doesn't seem to work. When running ifconfig, I notice that the eth0 and wlan0 adapters appear to be on different subnets, which indicates that the wlan0 adapter is running in AP mode.

Next I've tried turning off the AP mode (sudo systemctl stop hostapd, as described here), but that didn't seem to have any effect either. ifconfig still shows the two adapters on different subnets (and I get not Internet access when I pull the cable).

I've also tried running sudo update-rc.d hostapd disable to stop the hostapd service from starting up at boot, but that didn't work either.

Any ideas to what I could try next? And please keep in mind my limited Linux knowledge when suggesting a solution :)

4

I managed to figure this out when I found this documentation for how to set up the Pi as an access point. But it wasn't "just" to do the setup in reverse order (i.e. disable the dnsmasq and hostapd services), as the SD Card image in use doesn't seem to use the dnsmasq service.

What my solution finally ended up to be, was as follows:

  1. Stop the hostadp service:
    sudo systemctl stop hostap

  2. Edit the dhcpcd.conf file:
    sudo nano /etc/dhcpcd.conf

  3. Inside dhcpcd.conf, remove/comment out the lines related to the static IP address (in my case, the last two lines in the file):
    #static ip_address=192.168.115.1/24
    #static routers=192.168.115.1

  4. Reboot:
    sudo reboot

protected by Darth Vader Dec 30 '18 at 16:35

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.