I was checking if there were any updates for my raspberry, so I ran:
sudo apt-get upgrade

There are quite a lot of packages, I installed everything, but when my Raspberry starts to setting up the rsyslog package it hangs up.
I waited for more than 10 minuted, then I killed the process.
I tried again, getting the same result.

Any ideas about that?

1 Answer 1


Same thing happened to me--then I remembered RaspBMC highly recommends against using sudo apt-get upgrade. Which I assume was also a contributing factor to my install becoming trashed beyond recovery when RaspBMC tried to install updates. I had to do a clean install to get things behaving properly again.

Update 5/14/13:

The May 2013 update is supposed to fix the issues surrounding apt-get upgrade. I haven't tested it, but supposedly starting with this version of RaspBMC it will be possible to use apt-get upgrade without breaking anything

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.