2

I had an older pi (B+ model) running Raspbian Jesse and ran into a corruption issue, and finally picked it back up to replace the SD Card and I have been having issues installing Raspbian Stretch with Desktop. Originally I wrote the img file to the SD Card using Etcher and later installed it via Noobs, but each time it got hung up on different error messages. Mainly:

---[end Kernel panic - not syncing: VFS: Unable to mount root fs unknown-block(179,7)
random: crng init done

After trying this 4-5 times I transitioned to Raspbian Stretch Lite, and this installed successfully with no problem. After this was successful I tried with Desktop again, but it got hung up on the same error message again. Can anybody help explain:

---[end Kernel panic - not syncing: VFS: Unable to mount root fs unknown-
block(179,7)
random: crng init done

What is this error message and is there any way I can correct it?

NOTE: I am using the pi with a connected monitor & keyboard. I cannot ssh into the pi because the ip address isn't being assigned. I am using an 8GB Micro SD Card.

  • Welcome to Raspberry Pi! It is preferred if you can post separate questions instead of combining your questions into one on Stack Exchange. That way, it helps the people answering your question and also others hunting for at least one of your questions, so that we can address each point separately in detail. Thanks! – Aurora0001 Sep 20 '17 at 14:29
  • Question 2 is also likely answered here; give it a go, and if not, post a separate question with detail for that problem. – Aurora0001 Sep 20 '17 at 14:31
  • You can add the Pixel desktop to raspbian lite with sudo apt-get install raspberrypi-ui-mods or use sudo apt-get install --no-install-recommends raspberrypi-ui-mods lxterminal gvfs for a stripped down version. – bobstro Sep 20 '17 at 14:42
  • @Aurora0001 I apologize for my newbie move, I will make sure to separate my questions in the future. I was under the assumption that we had a limit on questions. – 1QuickQuestion Sep 20 '17 at 14:56
  • @1QuickQuestion No problem, and you probably are rate limited on questions (1 every 40 minutes if I remember correctly), but as long as your questions are received well by the community, you'll be able to continue asking more. The 40 minutes between questions gives you time to research and make sure each question is as good as it can be. Make sure you check all your questions on this site to see if there's a duplicate around, too, and you should be able to get an answer if not. Good luck! – Aurora0001 Sep 20 '17 at 14:58
2

The error ---[end Kechallengernel panic - not syncing: VFS: Unable to mount root fs unknown-block(179,7) random: crng init done

is often mentioned when a corrupt image have been transferred to a SD card or when a SD card is faulty or kernel bugs.

I have replaced a corrupt SD card due to this cause and that solved my challenge.

0

Some possibilities are:

  1. Your SD card is corrupted–try another one.
  2. Your image was corrupted when you downloaded it.
  3. Your kernel has problems.
  4. Other problems related to formatting your SD card. Sometimes you have to go to sdcard.org and download software to format your SD card in the best way posible.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.