1

There are plently of questions on this forum regarding shutdowns and how to perform them properly on a rpi, but I have not encountered anything like this before. Maybe I'm just being a linux n00b ¯_(ツ)_/¯ .

I recently burned a new image of Raspbian Stretch Lite on to my rpi model B. The system booted up fine, but when I went to shut it down, nothing would happen. After running sudo shutdown -h now, the system gives the standard "at [timestamp] system will halt" message, except it doesn't start shutting down; it just makes a newline with "pi@rpi~&" and pretends like nothing happens.

I've tried sudo shutdown -h -t 0, sudo halt, sudo reboot, poweroff and any other variations of those commands I could think of. Every time it spits out a new line and pretends I didn't even enter the command. The shutdown sequence just doesn't start. No errors are printed out. Why won't the system halt? Is there a fix?

  • 1
    Does 'tail -f /var/log/syslog' report anything useful ? Have you setup any cron jobs ? – CoderMike Sep 22 '17 at 15:55
  • @CoderMike tail doesnt report anything relevant, the problem does seem to occur only if I run apt-get upgrade. Rn im just unplugging, which isnt healthy for my sd card but sometimes i gotta reboot – Gabe Sep 24 '17 at 0:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.