8

I've been trying to setup the Pi as a WiFi AP, so that I can use it in Hotels to allow multiple devices to use the same WiFi connection. On the net there are multiple tutorials on how to do this. Such as: Pi 3 as a Wi-Fi Repeater

All works well up to the points where you should edit sudo nano /etc/network/interfaces. On my system this file is basically empty and has no references to either wlan0 or lan0. What I have in my "interfaces" file is:

interfaces(5) file used by ifup(8) and ifdown(8)

Please note that this file is written to be used with dhcpcd

For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

Include files from /etc/network/interfaces.d:

source-directory /etc/network/interfaces.d

Not sure where I'm going wrong and I've read through a lot of the tutorials. Could it be that the newest Kernel Version (4.9) has changes compared to the earlier version with regards to the networking?

6

There is NOTHING WRONG. See How do I set up networking/WiFi/Static IP for an explanation of the network settings in Stretch.

The interfaces file is largely empty because it is not necessary - I used to run a late Wheezy (using dhcpcd without one). It was only used because dhcpcd was incompletely setup, prior to Stretch.

The problem is no one has updated the tutorials.

I have not recently used the Pi in such a manner, and I am not sure the tutorials you are following are the best practice, but you should be able to adapt them - either that or go back to an old Raspbian.

See Wireless Access Point for a Foundation tutorial.

NOTE this is also not up to date, and will need to be adapted.

You will need to consider the following issues:-

  1. Predictable Network Interface Names
  2. Disable dhcpcd, either entirely or for the interfaces which do not need it.
  • Thanks for the quick reply. And there was me thinking I'm to dumb to set this up ;-) – Chris Sep 25 '17 at 0:45
2

If you want to put back the /etc/network/interfaces style network configuration, you need to uninstall the packages raspberrypi-net-mods and dhcpcd5.

I did so because I wanted to set up a token for building the local part of the IPv6 addresses (see https://unix.stackexchange.com/a/335633/253665) but found no way how to do this with dhcpcd.

Update

A simpler solution is to disable the dhcpcd.service:

systemctl mask dhcpcd.service

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.