0

I have recently bought a raspberry pi, and I have installed raspbian on it. I decided to change the default password, but after that every time I tried to login to ssh, it said permission denied. I tryed to change the password again, but it said invalid password. The only way I could change the password was with sudo. After that it worked a while but the next day it said invalid password again! I have no idea why it keeps changing but I need it to stop. Any ideas?Also, I have enabled ssh through raspi-config

  • Did you change your password through SSH or with a physical keyboard attached? – 88weighed Sep 29 '17 at 11:49
1

You might check if the keyboard settings are correct. The default keyboard setup is English (UK). If you are setting your password from a layout other than English (UK), you will actually set your password to something different than you want. For instance, if you think you're typing an @ (shift + 2), you're actually typing ".

Keyboard layout can be changed through raspi-config. Hope this helps.

0
  1. Are you connecting by WIFI? if so my answer might help as you need to do some setup.

  2. Have you ever been able to SSH into the pi before the password change? If you have a keyboard and monitor setup run the raspi-config

sudo raspi-config

The first option you can set "User password" for example for the username "pi".

then under "Interfacing Options" enable SSH.

  • Yes, I have enabled ssh through raspi-config – Camden Sep 28 '17 at 23:04
  • Is your pi connected to your router? I think you have not setup your WIFI – Dr.Rabbit Sep 29 '17 at 0:23
  • updated my answer hope it helps. – Dr.Rabbit Sep 29 '17 at 0:33
  • im commenting on my pi! of course internet is set up – Camden Sep 29 '17 at 1:34
  • is your pi user account locked? what happens if you passwd -u <your-username> – Dr.Rabbit Sep 29 '17 at 1:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.