2

I have a Raspberry Pi 3 that I have set up as a wireless bridge. I have a static IP on the ethernet port of 192.168.0.20, and a static IP on the bridge of 192.168.0.30. The Pi is running headless, so I do everything over ssh. Is there a way to ssh into the Pi once the bridge is connected? I have tried ssh-ing into 192.168.0.20 and 192.168.0.30, and both say "Network error: connection timed out". I am on Windows using PuTTY to connect.

For a little more information, I have the Pi connected to Ethernet, and I am using hostapd to create a Wi-Fi network. Everything works properly, I can connect to the Wi-Fi network and access the internet, but I cannot ssh into the Pi to change any settings, or even to issue a shutdown command.

  • How have you defined the bridging? – Charemer Sep 29 '17 at 12:44
  • I have bridge=br0 specified in the hostapd.conf file. The bridge is defined in /etc/network/interfaces as: 'auto br0 iface br0 inet manual bridge_ports wlan0 eth0 bridge_stp off bridge_maxwait 5 wpa-iface wlan0 wpa-bridge br0' I also set the static ip_address, static routers, and static domain_name_servers for both eth0 and br0 in /etc/dhcpcd.conf. – millercb Sep 29 '17 at 14:48
  • I'm afraid I'm not familiar with that method. Using Hostapd to make the RPi work as a hotspot I've used forwarding with IPtables to enable bridging. And have no problem ssh to either the wlan IP or the eth IP addresses. I used information from the following page : frillip.com/… incase that's any help. – Charemer Oct 2 '17 at 9:16
  • I have done that method before. It works to connect to Wi-Fi, but I switched to the bridging method because I need them to be on the same network. I have a Chromecast on my network, and I want to control it even when I am connected through the Raspberry pi. Bridging like I am allows me to do this, I just can't ssh into the Pi once it is set up. – millercb Oct 2 '17 at 9:57
  • You may find this troubleshooting page useful microhowto.info/troubleshooting/… . From that I get that once the bridge is active the interfaces are bound to the bridge, so you need to also bind an IP address for the bridge host to the bridge and then use that IP to connect. I don't have anything spare to test on at the minute so I can't offer that as an official solution. – Charemer Oct 2 '17 at 11:42
0

In this stack overflow question it said that the issue is caused by " a conflit between two DNS servers : isc-dhcp-server & udhcpd" and it's been solved:

The solution was to reinitialize the RPI and install only one of this two servers (udhcpd in my case)

  • 1
    This is not the problem. First of all, isc-dhcp-server and udhcpcd are DHCP servers, not DNS. Second, isc-dhcp-server is not installed on my pi. Since I have the Ethernet and Wi-Fi bridged, the main router on my network is serving as the DHCP server. – millercb Sep 29 '17 at 6:23
  • The problem looked the same to me based on the info of the first post :( – Luis Diaz Sep 29 '17 at 6:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.