1

I have a Pi 3 and a Pi Zero. I have a sandisk sd card a no name sd card. My Pi 3 will boot with both sd cards. The Pi zero will only boot with the sandisk. I am using the same latest image on both cards. The Pi Zero performed as if there was no sd card ( no LED activity)

I have tried:

  • multiple no name sd cards formatted re imaged, all using win32 disk imager
  • performed sudo update, upgrade, dis-update and rpi-update
  • copied the boot from one to the other.
  • Attempted with RISCOS
  • Attempted NOOBS v 2.4.4
  • Attempted Stretch light

After placing the old SD card into the pi zero for about 5 min I pulled it out to check the logs. I see not update in any logs from /var/log/

  • Pi zero 1.3
  • SD card 8gb class 10
  • Sam power used for Pi3 and Pi zero

Why would the Pi zero be sd card sensitive? any other troubleshooting tips?

  • Possibly, I looked but it and no answers. I do not have rep high enough to post a comment. – KMPY Sep 29 '17 at 16:30
  • I'm not 100% sure, but if I remember right a ARMv8 (Raspberry Pi 3) kernel can't run on a ARMv6 (Zero). To check the running kernel version, submit the command uname -a in a terminal. – MatsK Sep 29 '17 at 17:09
  • Thank you, if this was the case the the Sandisk card would not work in the pi zero. I must trying to identify if there is a possible hardware limitation? I have tried using the same boot partition on both sd cards as well. Tried to exspand the system before placing it on the pi zero, and still no luck. – KMPY Sep 29 '17 at 17:23
  • and you checked the kernel version? – MatsK Sep 29 '17 at 17:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.