0

I have deleted user pi and have another user name in the sudo group for installation. I have locked the root account and don't know the password of my NOOBS image. I have created a 'normal' user.

using the sudo capable user i did the following in a terminal sudo apt-get install emacs

the installer has put the emacs icon in 2 places on the start menu that's ok. The problem is there is no emacs icons on the 'normal' users start menu. Whilst logged on as the 'normal' user i can run emacs.

i thought the question was how do i manually add (and remove) items from the start menu? but it's actually why can't the 'normal' user not see the emacs24.desktop file in /usr/share/applications

0

Did you login to the normal account when you did it? There’s actually and admin account you can login and install apps on the pi, and you might have done this, and anything done here won’t transfer over to the normal user, you must repeat the install process on the normal user account I

  • @sjfklsadfjks after reading your reply I tried creating a new user. All ok on start menu. With a bit of deluser and adduser I now have a working 'normal' user. Ain't happy it's not a solution it looks like a bug in raspbian or pixel – rhubarbdog Sep 30 '17 at 18:31
0

Try using sudo -i to install it... That always worked for me. If the new user is in every group pi was in (except pi group), it should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.