1

I have a Micro SD card with 2017-08-16-raspbian-stretch on it. I confirmed that the cards content matched the img file exactly. Now I put the card into my Raspberry Pi Zero W and connected hdmi, keyboard, mouse and finally power. When it was finished booting, I clicked the WiFi icon in the top right corner of the screen and selected my WPA2 home WiFi, entered my password into the "pre-shared key" field and clicked ok. Nothing happened. It's not connecting.

In the past I have always connected by manually adding the credentials to /etc/wpa_supplicant/wpa_supplicant.conf. And that works fine.

So what is going on here? This must be a bug in the image, right?
Is there a known way to fix this?

Btw another problem most likely related to this one is that I cannot use raspap-webgui. I mean I can open the web interface, but when I click something, for instance the button that enables/disables wlan0, nothing happens.

Also, I should mention that I'm currently unable to re-flash my cards properly because of another unresolved issue. So flashing a newer image is not an option atm.

1

I had the same problem as you with wifi, to fix it you need to add the following o /etc/wpa_supplicant/wpa_supplicant.conf

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

Network={
ssid="nowan"
psk="12qwaszx"
key_mgmt=WPA-PSK
}

Change the ssid and password to what you are using.

Then add the following to /etc/network/interfaces:

allow-hotplug wlan0
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Finally run:

sudo systemctl enable wpa_supplicant.service

and reboot

  • I wanted to reply to cariboo but haven't got enough rep. Anyway, if you are stuck on a headless mode, and must do this via another computer using SD-card reader, then you do the following as he did after mounting the card and you put: sudo systemctl enable wpa.supplicant.service in the /etc/rc.local file. You should be able to login without any reboots. After you get connection, comment out the line or remove it as you don't need it anymore. I got this problem too after jessie to stretch upgrade. – Ole-Henrik Jakobsen Dec 9 '17 at 0:06
1

I think cariboo's code:

Network={

should be (lower case n):

network={

At least that was the case for my Stretch with my Pi W.

(also wanted to reply to cariboo but haven't got enough rep)

0

This was happening to me on an rpi3 with built in wireless as well after i used it as a sever for like a year. My best guess is that it’s the wireless card itself that’s damaged, and because of this the card isn’t recognized by the software. Maybe a defective pi zero?

  • No, as I said it works fine when I put my credentials into /etc/wpa_supplicant/wpa_supplicant.conf. So the chip is definitely fine. I suspect a sort of permission issue. – Forivin Sep 30 '17 at 14:23
  • Are you logged into the sudo desktop or the normal desktop? That may be the issue because if you need to sudo into the conf file to edit it, it may only be for the sudo desktop – sjfklsdafjks Sep 30 '17 at 14:42
  • I just let the pi boot and when it finished I was on the desktop without logging into anything. I don't know if that's the sudo desktop or not. – Forivin Sep 30 '17 at 15:33
  • Default boot is normal user, try booting to cmd, and start the desktop with the sudo command, and then try the wireless desktop interface. This should rule out some variables for us – sjfklsdafjks Sep 30 '17 at 15:46
  • 1
    I'd rather not. Running stuff with root permissions that shouldn't require them usually leads to more problems than it actually solves. I hardly think that the user is expected to do that in order to use the desktop properly. – Forivin Sep 30 '17 at 18:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.