-1

I recently switched to stretch, the latest version of raspbian os on my raspberry pi 0 (not the w model) I cannot get any peripherals to work; mouse, keyboard, or wireless adapter. I tried my pihat USB hub, as well an otg cable. Is there any known compatibility issues, and how might I fix them?

0

I assume that you have a video screen and it rpiz is booting ok? I also assume you are using a USB hub to achieve the connection between keyboard and mouse to the rpiz? Have you checked that same combo works on a PC? Barring defective cables, are all USB cables master/slave (the usual kind).

I have a zero-w so can't comment on the wifi. You can use the same microsd that works on a rpi2/3 in the zero. Set it up for wifi and enable ssh on another rpi, boot using that microsd and the zero will work just the same. Obviously you'll need to use the same type of wifi dongle in the zero as you did when setting up the other rpi. Once the zero has booted, you can use putty to manage remotely.

  • Yes it boots fine, the hub isn't the problem, because none of the peripherals work with just an otg adapter either, all the other items work absolutely fine in a pc. – Jebidieah Cornell Oct 8 '17 at 15:34
  • Have you re-tried the old version of the operating system? I have had problems with the zero not booting at all if it isn't shutdown properly. Just pulling the power leaves the ssd in an unstable state. I now have three ssds that cannot be zapped with new os. – Microchip Oct 20 '17 at 9:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.