0

Heyo everyone!

I was working on a schoolproject on my Pi today when I tried to connect to my Pi over SSH over WiFi. The Pi is connected to the school's WiFi network (Eduroam). The day before this I was able to SSH into it over WiFi just fine. Now I can't SSH into it nor can I ping it. A friend of mine is able to SSH into from his PC and SSH from my phone also works fine. So my laptop and also a laptop of another friend are not able to SSH into the Pi. I did setup the Pi as a wireless Hotspot the day before but I reverted all the changes again plus I stopped the dnsmasq and hostapd services.

Here some more info:

ifconfig:

eth0      Link encap:Ethernet  HWaddr b8:27:eb:1f:c3:71
      inet addr:169.254.228.189  Bcast:169.254.255.255  Mask:255.255.0.0
      inet6 addr: fe80::33bd:2ec6:f740:4871/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:1614 errors:0 dropped:0 overruns:0 frame:0
      TX packets:1882 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000
      RX bytes:147595 (144.1 KiB)  TX bytes:252748 (246.8 KiB)

lo        Link encap:Local Loopback
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:238 errors:0 dropped:0 overruns:0 frame:0
      TX packets:238 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0
      RX bytes:18386 (17.9 KiB)  TX bytes:18386 (17.9 KiB)

wlan0     Link encap:Ethernet  HWaddr b8:27:eb:4a:96:24
      inet addr:145.28.231.138  Bcast:145.28.231.255  Mask:255.255.252.0
      inet6 addr: fe80::ba27:ebff:fe4a:9624/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:2704 errors:0 dropped:43 overruns:0 frame:0
      TX packets:1871 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000
      RX bytes:229077 (223.7 KiB)  TX bytes:309539 (302.2 KiB)

iwconfig:

wlan0     IEEE 802.11bgn  ESSID:"eduroam"
      Mode:Managed  Frequency:2.412 GHz  Access Point: E8:65:49:A6:CD:11
      Bit Rate=65 Mb/s   Tx-Power=1496 dBm
      Retry short limit:7   RTS thr:off   Fragment thr:off
      Power Management:on
      Link Quality=50/70  Signal level=-60 dBm
      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
      Tx excessive retries:0  Invalid misc:0   Missed beacon:0
  • What are you using to connect? It's outputting something? – Luis Diaz Oct 5 '17 at 13:52
  • I'm using the ethernet interface to still have access to the pi. – Marijn Stam Oct 5 '17 at 14:02
  • I mean what OS and what program (like putty, a terminal, etc) – Luis Diaz Oct 5 '17 at 14:03
  • Oh my bad, I've tried both PuTTy and Bitvise SSH client. – Marijn Stam Oct 5 '17 at 14:05
  • Are those programs giving you any output? (error message) – Luis Diaz Oct 5 '17 at 14:06
0

Sorry for replying late (OP here), but here some more info on the issue. Have to post this as answer since I can't comment after I verified my account..

@Luis, the error I'm getting from my SSH client is as following:

Connection failed. FlowSocketConnector: Failed to connect to target address.
Windows error 10060: A connection attempt failed because the connected party 
did not properly respond after a period of time, or established connection 
failed because connected host has failed to respond

Unfortunately I don't have access to the Pi in question over the weekend but I did some testing on my Pi I have at home. Using the laptop I used before with no success, I was able to SSH over WiFi to my own Pi just fine. The situation is essentially the same. SSH over WiFi, both on the same network. Only the Pi is variable in the situation but it's weird since others were able to connect over WiFi just fine. Could it be that the Pi and my laptop were connected to different access points so that the 2 machines were on different subnets or something? I'm really puzzled at the moment.

One thing I have noted is that the original Pi was dropping RX packets on the wlan0 interface, whereas my own Pi isn't dropping any. Could those packets be from the SSH requests?

  • it says: "...established connection failed because connected host has failed to respond" So, it's seems that the pc is blocking the connection if that happend to your computer. Do you have any firewalls in the router or your computer? – Luis Diaz Oct 9 '17 at 6:19
  • It can't possibly be the router that's blocking the connection since other people were able to connect through the same router (all on Eduroam network). I've also tried disabling the firewall on my own laptop but that didn't change a thing. – Marijn Stam Oct 9 '17 at 6:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.