3

i have a issue with slow pip on Raspberry PI 1 on fresh install Raspbian Stretch.

When i ran pip freeze it take a long time.

pi@raspberrypi:~ $ time pip freeze > /dev/null

real    0m43.337s
user    0m39.600s
sys     0m1.170s

I tried reinstall 2 times and still same. Have someone idea where can be problem?

2
  • Same problem on the Pi2 and 3: On a RPI3, a simple pip --version took about 6 seconds to complete. Using Pi3, even nearly 9 seconds. This seems also affecting packages installed by pip like docker-compose. Here, a simple docker-compose --version takes about 7 seconds. Did you find any solution on this issue? Other tools like docker itself are quite fast (100ms)
    – Lion
    Oct 21, 2017 at 12:48
  • @Lion no, i didn't found any solution :/ i'm quite upset because pip is unusable with this 'speed'
    – sunny
    Oct 23, 2017 at 7:21

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.