0

I am trying to connect for the first time to a Raspberry Pi 3 with a Macbook air and an ethernet connection. I do the following steps:

  1. Insert Ethernet cable into Macbook (with a new thunderbolt-ethernet adapter bought yesterday) and Pi3.
  2. Enable internet sharing.
  3. Go to system preferences/network but Thunderbolt-ethernet is not connected.

I'm powering the board from the micro usb port.

Unfortunately I don't have a monitor and keyboard neither access to a router. Any idea why Macbook doesn't detect the board?

2

You CAN NOT connect to the Pi using ICS from the Mac (or any other computer) because ICS bridges the incoming connection to the Internet - which is what it is designed to do.

If want to connect to the Pi turn ICS OFF and see Connecting a Computer to the Pi in How-do-i-make-serial-work-on-the-raspberry-pi3 - of course, the Pi will NOT have connection to the internet.

You can have ICS OR direct connection, not BOTH.

Better still connect the Pi to your router, the way it was designed to be used, and you can have both.

If you don't have access to the router enable WiFi on the Pi. There are instructions to enable WiFi on a headless system.

2

@Giovanni - not sure if you have resolved the issue connecting your RPi3 to your Macbook Air. I had the same issue but I'm using RPi3B+ and Macbook Pro (2015) using thunderbolt-ethernet adapter.

Here's what I did to successfully connect my RPi3B+ to my Macbook Pro via the thunderbolt-ethernet adapter.

1. In the System Preferences > Network > Thunderbolt Ethernet - click the "Advanced..." button to bring up the additional options.
2. In the "Hardware" tab, you can try the following settings:
   - Configure: Manually
   - Speed: 100baseTX
   - Duplex: full-duplex, flow-control, energy-efficient-ethernet
   - MTU: Standard (1500)
   - uncheck the AVB/EAV Mode
3. Click the "OK" button and "Apply" the settings for the said network device

Now your RPi3 should connect to the internet. You can try to ping raspberrypi.local to see the IP address. It usually is in the range of 192.168.2.x and if you want, you can ssh to it directly using ssh pi@raspberrypi.local - considering you did not remove the user pi and your hostname is still raspberrypi - if not change the following user and hostname accordingly.

Hope this helps. I tried to find a solution but to no avail.

1

Normally you would set a static ip address for direct connection eg.

IP of OSX: 192.168.1.1
IP of RPi: 192.168.1.2
Subnet mask on both: 255.255.255.0
Default gateway on both: 192.168.1.254

Raspberry Pi settings sudo nano /etc/network/interfaces

auto lo

iface lo inet loopback
iface etho inet static
address 192.168.1.2
netmask 255.255.255.0
network 192.168.1.1
broadcast 192.168.1.255
gateway 192.168.1.254

allow-hotplug wlan0
iface wloan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

As you dont have access to a keyboard and mouse that is not going to help.

Because you dont have access to a router that means you have no DHCP server. The DHCP server is usually running on most routers and is responsible handing out ip addresses ect. So another other option is to run a DHCP server on you pc.

https://macosx.com/threads/howto-setup-dhcpd-server-on-mac-os-x-workstation.14022/

https://www.howtoforge.com/dhcp_server_linux_debian

http://dhcpserver.sourceforge.net/windows-and-linux

  • Thanks for your answer. The problem was that I was given and told that the sd card already had the Os installed, instead it was empty. – Giovanni Oct 7 '17 at 10:48
  • oh wow, would not have guessed that lol – Dr.Rabbit Oct 7 '17 at 12:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.