1

I've just bought a new Raspberry Pi Zero W v1.1 2017 and i already have a connection problem with putty over ssh.

Things i've done so far:

  • downloaded 2017-09-07-raspbian-stretch.img and burned with Win32DiskImager on micro sd

  • created an ssh file in the root folder

  • created wpa_supplicant.conf file containing:

    network={ ssid="Redmi4N" psk="12345678" key_mgmt=WPA2-Personal }

*also tried with key_mgmt=WPA2-PSK or without that line

When i try to connect with putty at raspberrypi i get the following error:

Unable to open connection to raspberrypi Host does not exist.

*same thing for raspberrypi.local as a host

Then, i've tried to check the connections with Advanced IP Scanner as i have read on forums but still nothing; it is not shown in there.

Am i doing something wrong? What else shoul i try?

PS:Using Windows 10 and the latest version of putty.

  • 2
    Did you enable ssh? See How do I set up networking/WiFi/Static IP You don't need key_mgmt for normal network. Another possible issue is the unusual image size with recent Raspbian - using Etcher avoids this. – Milliways Oct 7 '17 at 22:47
  • AFAIK Windows 10 doesn't support Zero-confout of the box, try entering IP. – Milliways Oct 7 '17 at 22:56
1

Raspbian Stretch has some 'tweaks' in the wpa_supplicant file before it will connect.

You need to add a dummy network connection.

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=AU
network={
scan_ssid=1
ssid="NetworkName"
psk="Password"
key_mgmt=WPA-PSK
}
#fake network workaround for headless Raspberry Pi Zero
network={
ssid="fakessid"
psk="fakepass"
key_mgmt=WPA-PSK
}

or you could use the Open Source Tool I have developed and host on GitHub Raspberry-Pi-Zero-Wifi-Setup-Tool

  • Why do you keep posting this? What evidence or reference do you have? The normal setup works OK for the rest of us. – Milliways Oct 7 '17 at 22:50
  • i've done that plus removing key_mgmt=WPA2-Personal and it worked. Thank you very much! – m3tsys Oct 7 '17 at 23:03
  • @Milliways If it helps people, and works for people, whats your issue? – Dr.Rabbit Oct 8 '17 at 3:26
  • 1
    This just becomes one of the urban myths, which waste people's time, and don't actually help them. There are lots of them in the Pi world. If you put your finger in your left ear before booting the Zero it may help, but I wouldn't recommend it. I am quite sure if the OP just deleted the key_mgmt it would have worked. Many of the problems people post are from following incomplete or inaccurate tutorials. – Milliways Oct 8 '17 at 4:36
  • Well I cannot headless boot a Rpi Zero W 1.3 without it. – Dr.Rabbit Oct 8 '17 at 4:40
1

You seem to be over complicating the setup, which often introduces problems.

  • Download and write the image to card
  • Boot the image and change the default password
  • Enable SSH
  • Install wpagui and manage your required WiFi network, obtaining an IP
  • Use putty to connect to the Pi by IP

Windows 10 can now run Linux Subsystem (Ubuntu CLI) which can terminal SSH straight to the Pi.

Using 'Fing' (to scan) and 'JuiceSSH' (for SSH!) on an Android phone/tablet, connected to the same network, is perfect for quick tweaks or bedtime connections.

0
  1. go to Add/Remove programs and uninstall all Bonjour and Bonjour print services
  2. Instead of the registry edit, the group policy editor can be used:

launch gpedit.msc Navigate to Computer Configuration > Administrative Templates > Network > DNS Client Enable the "Turn off Multicast Name Resolution" policy.

  1. Reinstall bonjour print services. Now you should be able to connect via raspberrypi.local in Putty

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.