3

I've just installed the latest version Raspbian.

After that i've tried to access the desktop version trough putty (sudo startx) but i get the following error:

X.Org X Server 1.19.2
Release Date: 2017-03-02
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.9.35-v7+ armv7l Raspbian
Current Operating System: Linux raspberrypi 4.9.41+ #1023 Tue Aug 8 15:47:12 BST 2017 armv6l
Kernel command line: 8250.nr_uarts=0 bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2708_fb.fbswap=1 smsc95xx.macaddr=B8:27:EB:12:90:94 vc_mem.mem_base=0x1ec00000 vc_mem.mem_size=0x20000000  dwc_otg.lpm_enable=0 console=ttyS0,115200 console=tty1 root=PARTUUID=c6990835-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet splash plymouth.ignore-serial-consoles
Build Date: 20 July 2017  09:07:00AM
xorg-server 2:1.19.2-1+deb9u1+rpi1 (https://www.debian.org/support)
Current version of pixman: 0.34.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Mon Oct  9 18:28:56 2017
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
modprobe: FATAL: Module g2d_23 not found in directory /lib/modules/4.9.41+

What should i do next?

| improve this question | | | | |
1

I'm not sure but as much as I understand you cant really open desktop environment using putty its a ssh client and ssh is text only ... Feel free to correct me !

Maybe try connecting using VNC to open it just head over to raspi-config => integration => VNC and enable it

| improve this answer | | | | |
1

this worked for me

  1. connect a display to the HDMI
  2. login to pi command line shell
  3. here we have to 2 things set resolution to default of the monitor and enable VNC to use from remote steps as follows sudo raspi-config go to Advanced option go to resolutions 1st one should be monitor defaults, OK go to interfaces go to VNC enable VNC by OK

  4. reboot with sudo reboot

  5. login again if not already and enter this code to start the GUI sudo xstart

  6. once GUI is working you can shutdown or use with VNC as you like

| improve this answer | | | | |
  • some tips: 1. check for sudo apt-get install xinit to install a display server if it doesn't exist 2. once that is done startx to start the GUI so you can use the window manager set up by update-alternatives --config x-window-manager. But once I logged out the GUI was off and I was returned to the shell each time, I couldn't fix this so logged into the GUI, copied my files and flashed my micro sd card with a fresh install of Raspbian-Stretch – snappercayt May 2 at 16:28
0

That modprobe: FATAL: Module g2d_23 not found … error is pretty harmless. It used to happen all the time.

Do you have a monitor attached? startx won't do much without one. It's also not typically used with sudo: that would mean that your X session would belong to another user. startx is seldom used any more, as you can set Raspbian to boot straight to desktop using raspi-config, option 3 Boot OptionsB1 Desktop/CLI.

If you don't have a monitor attached, you can still get a remote desktop from VNC. From raspi-config, select 5 Interfacing OptionsP3 VNC. You'll need a VNC viewer on the remote computer to see anything. If the remote display is really small, use raspi-config, option 7 Advanced OptionsA5 Resolution will allow you to set it to something better.

| improve this answer | | | | |
  • Unfortunately, it still happens, because people keep saying to ignore it, instead of fixing it. In the meantime 1000's of people have been asking about it for years. If someone would only bother to look for a fix or workaround from that message. – not2qubit Apr 27 '18 at 18:40
  • This post suggest to just remove /usr/share/X11/xorg.conf.d/99-fbturbo.conf. – not2qubit Apr 27 '18 at 18:43
0

Instead of SSH I use Remote Desktop from Windows 10, I am pretty sure other OS will run Remote Desktop. You can view the GUI from Remote Desktop, you just need to have either the IP address, or the RPi's name, which you can set in the Pi's settings.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.