0

So to begin, I have a brand new Raspberry Pi 3 B with Raspbian installed from NOOBS. I am trying to connect it to Wi-Fi however the GUI says No Wireless Interfaces. When I hop into Terminal, I can see wlan0, but if I use iwlist wlan0 scan it shows No scan results.

Most of the tutorials/forums/answers I have found involve using apt-get but I'm not connected to any network as I don't have any Ethernet to connect to and I can't get connected to Wi-Fi. I have tried editing the wpa_supplicant.conf file to include the SSID and key but to no avail. I have done the same with the /etc/network/interfaces file. I do have access to a separate computer where I can download items onto the microSD, however I cannot share the network for some reason (problem for a different time).

I tried downloading wicd onto the microSD and using sudo python setup.py install but because there's no network connection it fails to fetch the required files. I also have a USB Wi-Fi adapter but that has the same problems as the built-in Wi-Fi receiver on the RPi 3. I have tried numerous solutions with no real answer. Hopefully someone here can point me in the right direction or show me if I'm missing something.

1

So I am not sure where the answer went but the answer that solved this persons problem was to do a fresh install of the OS and then run the WiFi setup as there appeared to be a glitch in the OS.

  • I'm not really sure where it went either I thought I had already counted yours as correct... Either way thank you – Fumbles Oct 10 '17 at 17:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.