1

Whenever i try to reboot my rpi 3 using

sudo reboot

or

sudo shutdown -r

it fails to boot up again. However all works fine if power it down and power it up again.

I've had a look at booting troubleshooting documenation, and based on the LEDs behaviour that i'm seeing (both red and green LEDs steadily ON), the image in the sd card should be corrupt. However how can it be corrupt if it all loads and works fine when i power it off and on again?

I have 2 DTH22 sensors connected to the pi GPIOs, but I've had these connected and not giving any issue for the last 5 months. I have 3 "identical" setups with one Raspberry Pi, and 2 DHT22 sensors, logging data into a server and automatically rebooting once everyday. All three systems have worked with no issues in the last 5 months, and never fell over after the daily reboot until last weekend, when 2 out of the 3 rpi.

Now i can't reboot these rpi without unplugging the power. Neither via scripts, nor manual terminal commands.

Here is what happens in sequence, after i run sudo reboot:

enter image description here

enter image description here

enter image description here

Then the screen goes blank and stays like that forever, with no HDMI signla etc and with both red and green LEDs constantly ON

enter image description here

If instead I unplug the power, and plug it back, I see the same sequence as above, but doesn't get stuck to a blank screen, and instead goes through the usual boot scrolling info, and eventually boots up as normal.

0
  • Can you ping or ssh into the machines when they're in that state?
  • Do they have the same problem if you remove the sensors from the GPIO?
  • Can you check the SD cards from the affected machines in another Linux box with fsck?

The SDIO Drive errors suggest you're running quite an old version of Raspbian (possibly via NOOBs, which isn't ideal). Card corruption is the most likely reason for the problems, but it could also be that you're creating a process that's swapping, hence all the light activity.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.