Any one tried to host discourse (http://www.discourse.org/) on a raspberry pi? Or is there any issue that cannot be solved on a pie?

  • 3
    Why don't you try it and ask for help when you get stuck? Commented May 13, 2013 at 22:31

6 Answers 6


You can probably do it, given that Discourse is just a Ruby on Rails application. It will run slowly, given that Rails, Redis, and Postgres will all be sharing the limited processing power and RAM, but it should work.


No currently you cannot host discourse on Raspberry Pi 2

Install Ubuntu OK
Install Swapfile OK
Install Docker FAIL
- Error: you are not using a 64bit platform. Docker currently only supports 64bit platforms.
ARMV7 is 32 bit

  • It is not required to use Docker in order to use Discourse, it is just currently the recommended way. Installing Discourse by hand is still entirely doable.
    – Moshe Katz
    Commented Dec 9, 2015 at 14:46

The ARM cloud provider Scaleway adopted the building scripts to run Discourse on their platform. You do not need docker to run Discourse, however, there are some dependencies on x86/64-only libraries. Scaleway got around these issues by monkey-patching.

To install discourse, one has to follow the now unsupported installation guide for ubuntu: https://github.com/discourse/discourse/blob/master/docs/INSTALL-ubuntu.md


It is my understanding that Discourse requires 1GB of memory to compile all the prerequisites, so it's unlikely to run on the Pi. This is according to the following Guide, Installing Discourse on Ubuntu.

  • If you look on the discourse meta site, there are people who get it working with less than 1GB. You just need to configure it to use only 1 or 2 thin workers. I would assume that processing power is the bigger issue here.
    – Moshe Katz
    Commented May 19, 2013 at 19:45

You can probably run it by following guide.

I'm trying to do so, and facing a problem of installing mini_racer (libv8) gem on armv7l. If it can be solved, I don't see any other problems with running Discourse on a Raspberry Pi.

This information may be useful:


Official support was just added this week. The official install works on a Raspberry Pi running arm64 out of the box now.

Check https://blog.discourse.org/2021/12/2021-12-07-discourse-on-a-raspberry-pi/ for more details.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.