1

I've bought a Raspberry Pi 3 model b and a new design of Berryclip which is supposed to include the USB to serial adapter as an additional microUSB port for the Raspberry. Now I've been told that the power still has to come from the usual microUSB port.

Here are the instructions for the typical serial connector which are supposed to be the same as the instructions for the one I have:

The first thing we have to do is load the bootloader https://github.com/dwelch67/raspberrypi/blob/master/bootloader05/kernel.img?raw=true in the SD and feed the Raspberry. It is necessary to reset the Raspberry every time we want to load a new Bare Metal program, and this is done manually by unplugging and plugging in the power, or with the automatic method that we explained in the last section. We must connect the 3 cables that go from the USB-serial adapter to the Raspberry, with the third, fourth and fifth pins of the upper row of the GPIO port. The third pin is the ground, in the adapter is a black wire or marked with GND in the screen. The fourth pin is GPIO 14 or TXD, which corresponds to the RXD pin on the adapter. Finally the fifth pin is GPIO 15 or RXD and it is connected to pin TXD of the adapter. Note that the cables are crossed, the pin that transmits from the PC is the one that receives in the Raspberry and vice versa.

I haven't done anything with the kernel image as I have already flashed raspbian in the sdcard and besides I don't know what to do with that image. I've also added the line enable_uart=1 to the file /boot/config.txt of the raspberry.

Then I've looked some tutorials (RPi Serial Connection, Connect to the Raspberry PI Serial Port from a Linux PC that explain what I'm asking now but they assume the name of the device path is /dev/ttyUSB0. I don't have that device path at this point, with the power microUSB connected to a plug and the other to my PC. Like this:

enter image description here

So I have to find the name for the device path of the USB port connected to the Raspberry. I've looked other tutorials (Serial HOWTO, How to find which serial port is in use). But in my PC I don't get anything with that command:

dmesg | grep tyyS

Unless I connect the power microUSB to the computer:

dmesg | grep ttyS
[12741.466227] usb 2-1: ch341-uart converter now attached to ttyUSB0

I get an error when I run screen

❯ sudo screen /dev/ttyUSB0 115200
Cannot exec `/dev/ttyUSB0`: No such file or directory 
  • I use a USB to serial dongle to connect between a laptop and the Pi. The dongle serial end works at 3V3 TTL (i.e. it is Pi compatible). I plug the USB end into a laptop and the serial end into GPIO 14/15 (the Pi's RX/TX serial GPIO). That works. We need to know what YOU are using at the laptop end of the link and at the Pi end of the link. – joan Oct 18 '17 at 13:33
  • I think your tyy is a typo but doesn't change the meaning. It's correct that connecting the UART-to-USB adapter should appear as /dev/ttyUSB0 when it plugs into the host, even if the Pi is disconnected or turned off! The three pins (ground, TX, RX) all sound correct to me. I guess I'm a bit unclear on the question. You've flashed the Raspbian image, edited /boot/config.txt to say enable_uart=1, and you're still not seeing anything when you run sudo screen /dev/ttyUSB0 115200 from the Linux host? – jdonald Oct 22 '17 at 3:08
  • Does connecting in a usb 3.0 in the computer may have something to do with it? – Arturo Oct 22 '17 at 14:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.