I have downloaded NOOBS onto a 32GB samsung sd card. After powering up PI for a brief period it shows the option to select Raspbian OS or another but before I can select any it continues to reboot with the error ... not a ISO3166 code.

  • Looks like an issue with the locale or something. have you made any settings that affect language or other aspects like keyboard layout?
    – kwasmich
    Oct 19 '17 at 12:41
  • nope. I have not even been able to get to install Raspian pi OS through the NOOBS SD card (manually created SD card). As per suggestion by Mike below, I flashed the Raspbian Stretch with Desktop using Etcher and this time the Raspbian image kept coming on the screen (3 of them) but post that nothing displays on the viewsonic monitor connected via HDMI to DVI adapter. Along with the above change, I also switched the power supply to 5V-2A samsung mobile charger. Earlier the power supply I was using was providing very low current < 700mA. Oct 20 '17 at 5:15
  • Since I could not get the display to work which I thought could be due to power issue as well, I thought of connecting to raspberry pi without monitor. I connected the pi via LAN cables to a router and then trying to connect to it via ssh to the pi which kicks me out saying connection reset by peer and then subsequently connection closed by peer. Oct 20 '17 at 5:18

Download 'Raspbian Stretch with Desktop' and flash that direct to your sd card using Etcher.

Instructions : https://www.raspberrypi.org/documentation/installation/installing-images/README.md

Raspbian image : https://www.raspberrypi.org/downloads/raspbian/

Etcher : https://etcher.io

  • Thank you Mike. I reflashed as instructed above. This time however, I am seeing 3 raspberry icon on my screen and continues to go to blank screen and then displays 3 raspberry icon and the cycle repeats. FYI, I am using a DVI monitor with a HDMI male to DVI female converter for the display. I have connected a USB keyboard and a mouse. Oct 19 '17 at 15:40
  • I was using the power supply bought from Amazon (DIY Retails 3.3V and 5V Power Supply Module for MB102 Bread Board Arduino Raspberry Pi, Black). I noted that it has current output of < 700ma. I could not gracefully power off and had to switch off the power supply. I then connected my samsung mobile charger which had a 5V with 2A current rating. This time the Raspberry Pi screen came up and then vanished altogether. I am seeing black screen now. Please suggest. Oct 19 '17 at 16:04
  • Which model of Pi are you using? What resolution is your monitor?
    – CoderMike
    Oct 19 '17 at 16:18
  • I am using Pi 3 model B bought about 2 weeks back. I am using VA1912wb monitor from viewsonic and it has a resolution of 1440 x 900 Oct 19 '17 at 18:22
  • this time PI seems to be stable, but due to the display problem, I tried login in to the PI using SSH after connecting it to the router through LAN cable. I am getting connection reset by peer when I do SSH. The login prompt itself does not come. FYI, I created a "ssh" file in the root of the SD card and the screen showed that I should run a config script to reset the password. However after this the display is going blank, hence I tried to login via ssh and faced another issue as noted above. Oct 19 '17 at 18:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.