1

I am attempting to port forward 1883 to run MQTT server on my PI.

The port is forwarded through my router, but the PI is not connecting to it.

Experiments:

I ran a python server to test port forwarding. I ran the server on my PI for port 8000. I can access the server while on the network but not globally.

I then ran the same python server on my laptop. I am able to see the server over the internet (port forwarding is successful).

Only the PI is unable to use the port forwarding. My laptop is able to do so.

This makes me feel that my router and ISP are fine. I am able to access the server while I am on the network, so the application is running fine on the PI, just not outside it.

Anything I am doing wrong? This is a PI3 with a Raspian Streach that I installed yesterday.

1

It sounds like you have enabled port forwarding to your laptop's internal IP. Unless your laptop and PI are on the same IP address you would need to change the existing forward or add another to the PI's IP addr.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.