1

I bought 2 wireless controller from amazon called MATRICOM to connect them to my raspberry pi 3 running retropie 4.2

This controller works for PC, Android, PS3. It has a mode button so I can change the mode to keyboard or mouse or controller. I connected it via bluetooth and when i configured it as a controller everything goes fine but in games I can use only the arrows. When I configured it as a keyboard I can use only one controller because both of them keyboard and they work as one keyboard, but there is a problem with this also, the 1st controller I connect it will have issue with the buttons (like when I pressed the arrow to move, it also press a button to jump or to fire what ever the game is) but the 2nd controller works fine. If I connect the 2nd controller first, the 1st controller will have the issue, whatever the controller I connect it first will have the issue but the second one will bot have this issue.

I want to connect it as a ps3 controller and I tried all ps3 controller drivers and it is not connected. When I remove the cable and run the controller, the lights blinks but not connected wirelessly.

Note: when I connect it via usb it shows that I connect an xbox 360 controller.

I connect them to a pc and they worked fine with no issues.

How can I connect them to my raspberry pi 3 via bluetooth without any issue??

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.