I'm in a pinch. I'm trying to do a headless set up with a Raspberry Pi 3 running Ubuntu Mate because I do not have a hdmi screen close by. I was wondering, can anybody provide me with a link to a modified Ubuntu Mint image for the Raspberry Pi 3 that has ssh already enabled? If not, is there a way to manually enable ssh via config files? Thanks! (Putting a file named ssh in your boot directory only works on Raspbian, unfortunately)

I have been playing around with the idea of having the system run the "enable commands" on boot, but have not gotten anywhere. I've tried turning the ssh symlinks from init.d to rc* to "S02ssh" instead of "K02ssh". Is this even possible? Can I create a script that runs at boot time and enables ssh for me?

2 Answers 2


Supposedly there's a shortcut to reenabling ssh on Ubuntu Mate by adding a file under /boot however since there's several such questions that have gone unanswered I'll give you a generic way to do this on Linux and it should work for you.

Put Ubuntu Mate onto the SD. Mount the SD on a Linux computer. Ubuntu Mate 'should' have ssh installed its just disabled.

To enable it and with the sd card mounted as /mnt do

ln -s /mnt/lib/systemd/system/ssh.service /mnt/etc/systemd/system/multi-user.target.wants/

Edit /etc/ssh/sshd_config and confirm you can login with password and if necessary permit empty passwords if the default user account has no password.

Put the SD back in pi and boot and it should allow you to login.

  • This is definitely the route I had in mind, but unfortunately it does not work.
    – Mozzy
    Oct 22, 2017 at 19:39
  • This isn't working..
    – Abhik Bose
    Feb 27, 2018 at 8:18

You can enable SSH manually on Rasbian by mounting the sdcard on a PC and adding an empty text file called ssh without an extension to the boot partition.

  • 4
    Are you sure the question was about Raspbian?
    – techraf
    Oct 21, 2017 at 0:23
  • 3
    This does not work for Ubuntu Mate.
    – Mozzy
    Oct 21, 2017 at 0:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.