1

I am using my Raspberry Pi to set up a print station in a remote location, and I am using Google Cloud Print to send prints from my home. Everything works fine when I am booted to desktop on RPi, but when I use raspi-config to set it to boot into non-GUI mode, the prints don't get sent to CUPS.

One thing I've noted is that as soon as I use vncserver command on RPi to create a virtual desktop, the printing starts working again. However, after that, even if I kill the virtual display using vncserver -kill :<display number>, it continues to work. This makes me think that Chromium's services do not start until a display is created.

Am I thinking in the right direction? If so, how do I get this working without booting into GUI? The sole reason I don't want to have GUI is to reduce resource and thereby power usage.

One option is to have a shell script at startup to run vncserver command, wait and then kill the display, but I want to keep that as a last option.

  • It might be a .desktop file, some of them can be used by a desktop environment to start things when someone starts a graphical session. The .desktop file is just a text file with a command in it. If you were to run the command directly, it could work. If not: search for headless google cloud print server – John Keates Oct 22 '17 at 2:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.