2

I've been mounting it with sudo mount -t ntfs -o umask=000 /dev/sda1 "/media/My Book" but for some reason it now says mount: warning: /media/My Book/ seems to be mounted read-only when I do so, and ls -l shows it's correct. The drive has its own power supply and it works fine with my laptop, so I think the problem must be with the Pi. What am I doing wrong?

Update: Just to be clear, that command used to work, and it's read-only for EVERYONE, even root:

$ ls -l /media
total 8
dr-xr-xr-x 1 root root 4096 Apr 28 11:11 My Book

The contents appear the same way.

Update 2: Probably found the cause. From /var/log/syslog:

May 17 19:37:52 raspberrypi kernel: [   64.688724] NTFS driver 2.1.30 [Flags: R/W MODULE].
May 17 19:37:52 raspberrypi kernel: [   65.195397] NTFS volume version 3.1.
May 17 19:37:52 raspberrypi kernel: [   65.195439] NTFS-fs error (device sda1): load_system_files(): Volume is dirty.  Mounting read-only.  Run chkdsk and mount in Windows.

Probably should've tried looking there before...

3

ntfs is a kernel-based, read-only ntfs driver (actually you can modify a file or its attributes, but not its size).

Try mount -t ntfs-3g, which relies on fuse (Filesystem in USErspace).

1
  • mount: unknown filesystem type 'ntfs-3g' According to a comment on this question the ntfs option uses ntfs-3g. And the commanad I listed used to work...but now it doesn't. – Zelda64fan May 15 '13 at 12:54
1

Running chkdsk E: /F on Windows fixed it.

-3

@Zelda64fan You need to install this ntfs-3g module on your distro to make it work.

2
  • You should expand your answer to include how to install the module and why you believe that will fix the problem. if you read the other comments and answers I don't think your suggestion is the answer tot he OP's question. – Steve Robillard Apr 14 '15 at 11:47
  • The OP answered his own question, so you should update your answer to show how to figure out what to do and how to do it. – user1133275 Apr 16 '15 at 4:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.