1

I have a Raspberry Pi Zero V1.3. I recently tried making a portable device running Retropie.

I attached a TFT-screen using the ports on GPIO. After a while I was trying to install modules for the screen and Pi just turned off itself.

I thought it was caused by the cable I soldered to the usb pins so I desoldered it and managed to turn on pi again. But now the usb ports are not working. I tried plugging the usb cable in the other port and vice versa but no luck.

I was using a Usb to Ethernet adapter to connect it to the net. So now I am not able to control the raspberry pi or connect it to the network because the usb port is not working.

For the TFT screen I followed these steps: https://www.itead.cc/blog/raspberry-pi-2-8-tft-add-on-touch-function

So how can I fix the usb port or how can I connect my Pi to the internet to use ssh?

1

Your Pi has a serial port on GPIO pins 8 and 10 (see e.g. this pinout). If the OS you're running on the Zero has been configured to run a getty on that port you could use something like this to log in over the serial port.

Remember that you can always pop the SD card and make any necessary configuration changes on another computer. This can also give you a method for debugging things slowly:

  • Write a script that generates diagnostic information and have it run when the system boots and write that information to a file.
  • Pop the SD card, mount it on another system, and examine the generated file.
  • Repeat as necessary.

The simplest way to run something when the system boots is to add your commands to /etc/rc.local

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.