0

I have a raspberry pi 2, with a raspbian-stretch (2017-09-07) operative system burn into sd-card by using etcher-1.1.2 app. Raspberry works well!. I tryed follow many guides for mount sd-card operating system in Vrtual-Box(5.1.30) linux application, but at startup a black screen appears. I follow these steps:

  • umount sd card (Device /dev/mmcblk0) (/dev/mmcblk0p1 FAT32 boot partition, /dev/mmcblk0p2 Ext4 data partition)
  • use VirtualBox command: sudo VBoxManage internalcommands createrawvmdk -filename /home/user/Desktop/raw_file/file.vmdk -rawdisk /dev/mmcblk0 and appear: RAW host disk access VMDK file /home/user/Desktop/raw_file/file.vmdk created successfully.
  • start Virtual-box in root mode
  • create a new machine without hdd and operative system
  • add SATA controller and select file.vmdk I tried to mount and remount sd partition but nothing changed! Please, help me, thanks in advance. sdcard configuration
  • 1
    AFAIK virtualbox does not support ARM OS's. – Steve Robillard Oct 23 '17 at 21:50
1

You can't run an ARM Raspbian image on an x86 system. If you want to run the Raspbian Pixel Desktop you can download the x86 iso at raspberrypi.org

  • Thank Steve Robillard and 88weighed for your answers, my original intent was modify the /dev file of raspberry pi, by using emulation. But seem that it can't be done! Thanks a lot. – init0 Oct 23 '17 at 22:01
  • @init0 have you tried a live linux dvd – Steve Robillard Oct 23 '17 at 22:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.