0

What I need to do is to install ROS on a Raspberry Pi 3 (Model B) with Raspbian (I cannot use Ubuntu Mate). First, I tried to do it using Windows 10, with qemu, and following these instructions but I couldn't do it (believe me, I tried several times).

So now I installed Ubuntu 17.10 in a Virtual Machine and I'm going to do it from there. I want to use Raspbian Stretch, so I think I should use ROS Lunar. Can you please tell me the steps to follow? This is what I think I should do:

  1. Download Raspbian in Ubuntu

  2. Install Raspbian in my Raspberry Pi 3B

  3. Download ROS in Ubuntu

  4. Follow the instructions from the link that I put before. Can I use the terminal from Ubuntu?

0

Instructions for the first two steps can be found here:

I can't get the ROS pages to load? A quick look at the cached pages lead me to this:

Raspberry Pi 3 Robot Image – Details

Which had a link for a raspberry pi image with ROS already installed, but it does use ubuntu mate. What was the problem with Ubuntu? This might be an easier way to go?

Otherwise your linked install instructions should work once you ssh into the pi or use it's desktop environment if it has a screen etc.

It isn't clear what your Ubuntu virtual machine was for?

  • The ubuntu virtual machine is because i couldn't do it in windows 10 + qemu. I don't know what else to do. I need to use Raspbian because I have to use part of the job made by other students some years ago and it's not compatible with Ubuntu Mate. – Unnamed Oct 28 '17 at 5:11
  • Did the raspbian install work? Ah sorry, step back a little, what do you need windows 10 and qemu for? – Craig Oct 30 '17 at 10:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.