1

I configured my Arris TG852G router to forward port 80 to my raspberry pi private IP address. I also put port triggers on port 80. I have Raspbian OS on my pi. With Apache running and listening on port 80. So, the website will work on both external and internal ip address, but for only about 15 minutes. Then I'll get either this message

"The browser you are using may have difficulty receiving images and video. If you experience any issues viewing this page, we suggest using Internet Explorer, Mozilla Firefox, or Apple Safari"

Or a log in screen, or failed connection. The best thing I could come up with is on my arris router is to changed the NAT mode under LAN settings to Routed Without Nat. The problem with this is all devices connected to my home network can no longer reach outside my local connection. I've tried many things from changing to port 8080 or having port 80 redirect to 8080 on both apache and my arris router. I believe the main cause is the arris NAT. Is there anyway around getting my raspberry pi to ignore the NAT? Or I'm I looking at this wrong?

Port Forwarding Port Trigger

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.