1

I am following this tutorial :

http://www.widriksson.com/raspberry-pi-hadoop-cluster/

I am using Raspberry Pi 3. When I tried to test SSH connection same like the tutorial, I am getting:

ssh: connect to host hadoopmaster port 22: No route to host

Also I don't know if the file /etc/network/interfaces is the right file to put my network configuration :

iface eth0 inet static
address 192.168.0.110
netmask 255.255.255.0
gateway: 192.168.0.1

because It is empty and when I put the IPs in it, I can't connect to wifi anymore.

I tried also to put the static IP cofiguration inside /etc/dhcpcd.conf and I am getting the same above error when I try to open ssh connection.

I also added a host name and IP to /etc/hosts , which is not mentioned in the tutorial, but nothing worked.

enter image description here

  • You are using a 3 year old tutorial, written before the Pi3 existed, and there have been 2 OS upgrades since! – Milliways Oct 26 '17 at 9:09
  • Yeah, I know. This is the best tutorial I could found. So, do you know a solution for this? – Ali Zuhair Oct 26 '17 at 9:19
  • The top answer here should help – mintyfreshpenguin Oct 26 '17 at 10:28
  • 2
    Maybe it's just a confusion a confusion between hadoopmaster and hadoopMaster? – Technico.top Oct 26 '17 at 10:38
  • First question: Can you sudo ping to the target address? It is quite possible that there is indeed no route to the host. – SDsolar Mar 25 '18 at 5:23
1

There shouldn't be a colon : after gateway. Apart from that, you might be bothered by case sensitivity. You're connecting to hadoopmaster, but specified hadoopMaster.

0

Try to SSH locally from the same machine to verify that whether the ssh service is running.

Looks like you are trying to communicate over wifi and you are setting your network configuration for ethernet.

Also as @88weighed pointed out the : and case sensitivity.

Hope that helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.